Demo 3D Viewer

The Demo 3D Viewer is a limited-functionality version of Dynamic Graphics’ 3D Viewer that allows interactive visualization and manipulation of 3D models in the form of an encrypted faces files. Once an encrypted faces file is loaded, scattered data, polygon, vertical fault, 2D annotation, binary well display, and image registration files can be loaded. These capabilities are covered under the following chapters of this document:

- Introduction
- Loading the Demo 3D Viewer CD
- Demo 3D Viewer File Types
- Demo 3D Viewer Interface
- Appendices

Documentation Release Date: September 1, 2010

A Windows® or Linux® PC with 3D graphic capabilities is required to run the Demo 3D Viewer. Check with the local Dynamic Graphics representative for a list of specific hardware models and requirements.
Table of Contents

Chapter 1: Introduction .......................................................... 8
    The Demo 3D Viewer: 3D Display, Visualization, and Editing ....... 8

Chapter 2: Demo 3D Viewer File Types .................................... 19
    Encrypted Faces Files (.encn.faces) .................................. 19
    Scattered Data, Property Data, and
        Well Path Files (.dat, .pdat, .path). ............................ 20
    Vertical Fault Files (.vflt) ............................................ 27
    Polygon Files (.ply, .nvflt, .vply) ................................. 27
    Annotation Files (.ann) .............................................. 27
    Vue Files (.vue, ) .................................................... 28
    Image Registration Files (.imreg) .................................. 28
    Screen Dump Files (.rgb, .jpg, .bmp, .tiff, and .png). ......... 29
    Binary Well Display Files .......................................... 29

Chapter 3: Using the Demo 3D Viewer Interface .......................... 30
    Starting the Demo 3D Viewer ........................................ 31
        The Initial Screen Display ....................................... 31
            Initial Model Display ......................................... 32
            Elevation vs. Depth ........................................... 32
            Viewer Z Origin and Z Datum above MSL .................... 32
                Z Origin—Viewing Files Relative to any Vertical Datum ... 33
                Z Datum Above MSL—File-specific Vertical Reference .... 33
            Vue File Usage to Change the Initial Model Display ....... 33
            File Pull-down Menu .......................................... 34
            File Selection Window ....................................... 35
            Edit Pull-down Menu .......................................... 36
            View Pull-down Menu .......................................... 38
                View -> Lighting ........................................... 39
                View -> Axes and Labels ................................. 42
            Window Pull-down Menu .................................... 45
            Display Pull-down Menu .................................... 46
<table>
<thead>
<tr>
<th>Icon Buttons Around the Model Window</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query Pull-down Menu</td>
<td>47</td>
</tr>
<tr>
<td>Tools Pull-down Menu</td>
<td>47</td>
</tr>
<tr>
<td>Help Pull-down Menu</td>
<td>48</td>
</tr>
<tr>
<td>Open</td>
<td>50</td>
</tr>
<tr>
<td>3D Cursor</td>
<td>50</td>
</tr>
<tr>
<td>3D Cursor Positioning and Measurement</td>
<td>51</td>
</tr>
<tr>
<td>Location Tab</td>
<td>52</td>
</tr>
<tr>
<td>Options Tab</td>
<td>53</td>
</tr>
<tr>
<td>Measure Using Two 3D Cursors</td>
<td>53</td>
</tr>
<tr>
<td>Calculate Area Using Three 3D Cursors</td>
<td>53</td>
</tr>
<tr>
<td>3D Cursor Snapping</td>
<td>54</td>
</tr>
<tr>
<td>Set Lighting</td>
<td>54</td>
</tr>
<tr>
<td>Set Axes, Labels, and Captions</td>
<td>54</td>
</tr>
<tr>
<td>Demo 3D Viewer Mouse Pointer</td>
<td>55</td>
</tr>
<tr>
<td>Select Mode</td>
<td>56</td>
</tr>
<tr>
<td>Manipulate Mode</td>
<td>57</td>
</tr>
<tr>
<td>Screen Annotation Edit</td>
<td>57</td>
</tr>
<tr>
<td>Centering Tool</td>
<td>59</td>
</tr>
<tr>
<td>Reset View</td>
<td>59</td>
</tr>
<tr>
<td>Magnifier Tool</td>
<td>60</td>
</tr>
<tr>
<td>Reverse Background Black/White</td>
<td>60</td>
</tr>
<tr>
<td>Perspective/Orthographic</td>
<td>60</td>
</tr>
<tr>
<td>Inclination</td>
<td>60</td>
</tr>
<tr>
<td>Azimuth</td>
<td>61</td>
</tr>
<tr>
<td>Reset Inclination and Azimuth</td>
<td>61</td>
</tr>
<tr>
<td>X/Y Map View</td>
<td>61</td>
</tr>
<tr>
<td>X/Y, X/Z, and Y/Z Plan Views</td>
<td>62</td>
</tr>
<tr>
<td>Z Exaggeration</td>
<td>62</td>
</tr>
<tr>
<td>Reset Z Exaggeration</td>
<td>62</td>
</tr>
<tr>
<td>Lock Z Exaggeration</td>
<td>63</td>
</tr>
<tr>
<td>Zoom</td>
<td>63</td>
</tr>
<tr>
<td>Rotation While Zoomed In</td>
<td>63</td>
</tr>
<tr>
<td>Zoom In on an Exact Location</td>
<td>64</td>
</tr>
<tr>
<td>Reset Zoom</td>
<td>64</td>
</tr>
<tr>
<td>Pan</td>
<td>65</td>
</tr>
</tbody>
</table>
Reset Lookpoint ................................................. 65

Demo 3D Viewer Panel Window ................................ 66

File Selection Pane .............................................. 66
Right Clicking in the File Selection Pane ...................... 67
Changing the File Selection Pane Size .......................... 67

Slice Tab ........................................................... 68
Boundary Slicing .................................................. 69
Slider Handle and Value Manipulation ............................ 70
Value Boxes and Arrows ......................................... 71
Linked Scattered Data Point Slicing ............................... 72
Slice Animation ................................................... 73
Planar Slicing ..................................................... 74

Visible Tab ......................................................... 75
Discrete and Numeric Filter Lists ................................. 76
Discrete Attributes ............................................... 76
Numeric Attributes .............................................. 78
Linking Property Data Files and Property Faces Files in the Viewer ..................................................... 79

Render Tab .......................................................... 81
Volume Outlines .................................................... 81
Z Contouring ....................................................... 82
Fault Face Color .................................................. 83
File Transparency ................................................ 83
Wireframe Rendering ............................................. 83
Symbol Display ................................................. 84
Annotation File Display .......................................... 85
Annotation Line Width Scale ..................................... 85
File-specified Colors ............................................. 85
Annotation Z plane ............................................... 85
Data Line Display ................................................ 86
Line Display ..................................................... 86
Label Posting .................................................... 86
Tube Display ..................................................... 87
Binary Well Displays (BWDs) .................................... 89
Decimation Factor ............................................. 91
Spider Diagram Display ..................................... 92
Image Display .............................................. 92

**Edit Tab** .................................................. 94

Graphic Data Editor ........................................ 95
  Data Files .................................................. 96
  Active Edit File ........................................... 96
  To Select a File for Editing ............................... 96
  Lock the Edit File ........................................ 96
  Undo/Redo and Edit History .............................. 97
  Select Modes .............................................. 97
  To Select a Point Using the Pointer Tool .............. 97
  To Select Multiple Data Points ......................... 97
  To Select a Line of Data Points ......................... 98
  To Select All Data Points ................................ 98
  To Unselect a Point ..................................... 98
  To Unselect All Points .................................. 98
  Select Operations ....................................... 98

Edit Operations ........................................... 99
  Add ....................................................... 99
  Insert .................................................... 99
  Delete .................................................... 100
  Move ..................................................... 100
  Digitize Mode .......................................... 100

File Query .................................................. 101
  Query ..................................................... 102
  Info ..................................................... 102
  Edit Defaults ........................................... 103

Text File Editor ............................................ 104
  Open File to Edit ....................................... 105
  Save File ................................................ 105
  Save File and Update Viewer ............................ 105
  Add Line after Selected Line ............................ 105
  Insert Line before Selected Line ....................... 105
  Delete Selected Line(s) ................................ 106
Add Field to File ................................. 106
Delete Selected Field(s) ...................... 106
Hide Selected Field(s) ......................... 106
Make All Fields Visible ....................... 107
File Pull-Down Menu ......................... 107
Edit Pull-Down Menu ......................... 108
Image Registration ............................. 108

Appendix A: Screen Annotation Fonts .............. 109
  Sample Fonts .................................. 109
    Arial ....................................... 109
    Courier .................................... 110
    Century Schoolbook ......................... 110
    Times New Roman ........................... 111

Sample Point Sizes ........................... 111

Appendix B: Hot Keys .......................... 112

Appendix C: Demo 3D Viewer Glossary ............ 115

Index ......................................... 119
Chapter 1: Introduction

The Demo 3D Viewer is used to view and manipulate one 3D model (in the form of an encrypted faces file) and, after an encrypted faces file is loaded, scattered data, polygon, vertical fault, 2D annotation, binary well data, and image registration files can be loaded, provided the XY and Z units either match the faces file or are designated as “unknown” in their respective file headers. Examples of some of these data types are shown in the color figure pages, starting on page 9 (following this introduction).

This document discusses how to use the Demo 3D Viewer interface, as well as how to get the most out of the Demo 3D Viewer. The Demo 3D Viewer has limited functionality compared with the much more capable EarthVision 3D Viewer, the WellArchitect Viewer, and the CoViz 4D Viewer. This document covers only the functions available in the Demo 3D Viewer.

Appendices and a glossary of terms specific to the Demo 3D Viewer are available at the end of the Demo 3D Viewer document.

The Demo 3D Viewer:
3D Display, Visualization, and Editing

The Demo 3D Viewer interactively displays and manipulates encrypted 3D models (known as encrypted faces files), scattered data files (.dat, .pdat, and .path files), vertical and non-vertical fault files, polygon files (both .vply and .ply files), and image registration files, providing the user with numerous display, editing, and capture functions. The initial display includes a command menu, the model and ASCII data, and a key, known as the color key. Once in the Demo 3D Viewer, graphic aspects of the display can be altered, such as the view angle, vertical exaggeration, and ranges of the X, Y, Z, and P values displayed, and fault files or polygon files can be displayed. A host of menus are available that can be used to obtain a multitude of different images. Hot keys, which are single keystrokes representing commands, are also available for nearly every menu command.

These capabilities offer powerful tools for analysis, enabling the user to visualize the data prior to modeling, as well as view the final modeled surface, structures, or property. Beyond the basic capabilities of rotation and slicing, some of the more powerful analytical tools include:

- Viewing and editing scattered data files prior to calculating a model
- Editing or creating additional scattered data files based on the model
- Displaying seismic data along with models for model and interpretation verification
- Saving screen displays
Chair mode view of a two-layer model with an isosurface, well tube, and well data displayed, along with an image overlay.

Faulted 3D property model
EarthVision structural model in thrust terrain with well data and surface imagery.
Subsurface data courtesy of Marathon Oil Company.

EarthVision structural and cellular model with well data for a North Sea salt dome.
Simplified 3D Extensional model built in EarthVision.

Upscaled cellular property model based on EarthVision property/structural model.
North Sea faulted turbidite channel model built in EarthVision, displayed with well and cellular data.
EarthVision structural models displayed in the Demo 3D Viewer.

Acid Neutralization Potential Model.
Color-filled contour map of elevations displayed, along with data, on top of a single faulted zone.

Fault surfaces displayed with data color-coded by fault block.
Full 20-layer, faulted model displayed, with
data, with chair mode off in one zone.
Brisbane Landfill:
Four-layer model of deformed, interfingered, lithologic units.

Processing by Queensland Supercomputing Laboratories of CSIRO. The Brisbane Landfill is operated by Pacific Waste Management. Well tubes are for display purposes only.
Site annotation displayed above contaminant plume and input data
Chapter 2: Demo 3D Viewer File Types

Several different file types are used in the Demo 3D Viewer. Most of these files are initially created elsewhere in EarthVision (e.g., in Faces File Generation). The file types are discussed in the following sections.

Input files to the Demo 3D Viewer consist of almost every file type used in or created by EarthVision and the other DGI programs, such as WellArchitect. The input files include encrypted faces files, scattered data files, 2D grids, 3D grids, surface annotation files, scattered and property data files, well path files, vertical and non-vertical fault files, vue files, color files, list files, well target files, image files, cellular grids, Binary well displays, groups, and attribute surfaces files. These files are created either in the Demo 3D Viewer, EarthVision, or by using a system editor. The Demo 3D Viewer input files are not used to “calculate” other data files, rather they are used for display purposes: either to be viewed, or in some way determine the view. Each file type is discussed in more detail next.

Encrypted Faces Files (.encn.faces)

Encrypted faces files are supplied with the Demo 3D Viewer program. These binary files contain X, Y, and Z coordinates for each user-specified isovalue level, making them essentially 3D contour maps. Two types of encrypted faces files exist: sliced and unsliced. Unsliced faces files can be sliced at any arbitrary location (refer to the Slice Tab section of this document) and can be generated by the Geologic Structure Builder, the WorkFlow Manager, or in Faces File Generation. All encrypted faces file names must end with the suffix .encn.faces.
Scattered Data, Property Data, and Well Path Files (.dat, .pdat, .path)

ASCII scattered data, property data, and well path files can be displayed and, if desired, edited in the Demo 3D Viewer either with or without a faces or grid file. These files could, for example, represent either scattered data that were used as input to gridding or points along lines of any kind, such as well bores or seismic lines. These data files can be used to view input data prior to gridding, for editing, as a reference file unrelated to the faces file, and to view any Z- or P-field for an entire data set.

Multiple Z-fields can be selected when displaying a scattered data file. The default colors used for each Z-field differ: yellow is used for the first Z-field selected, then (in order) green, red, blue, orange, magenta, brown, and white for subsequent fields, cycling back through the colors. Z-fields with line IDs or well IDs are drawn with lines connecting each point along a given X,Y path, as appropriate. Data editing and data animation cannot be performed when multiple Z-fields are selected.

The file must, at minimum, contain an X, Y, and Z field. A P-field is optional. Other optional fields are also available. The Demo 3D Viewer recognizes the following field names in scattered data, property data, and well path files:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>The spatial X location of the data point.</td>
</tr>
<tr>
<td>y</td>
<td>The spatial Y location of the data point.</td>
</tr>
<tr>
<td>z</td>
<td>The spatial Z location of the data point.</td>
</tr>
<tr>
<td>p</td>
<td>The property value at the X,Y,Z location.</td>
</tr>
<tr>
<td>=</td>
<td>In addition to the Z-field and P-field names (Z and P), any fields that do not have one of these “special” names (e.g., X, Y, feature, etc.) are considered to be potential Z- or P-fields (in .dat and .pdat files, respectively).</td>
</tr>
<tr>
<td>comment</td>
<td>A comment field is available so that text strings associated with a data location can be posted when querying a data point in the Demo 3D Viewer.</td>
</tr>
<tr>
<td>lineid, wellid</td>
<td>Data points with the same value in this field are assumed to be located along the same line and will be connected by a line in the Demo 3D Viewer.</td>
</tr>
</tbody>
</table>

Note: If a line ID field is blank, then the points are drawn connected to the previous points in the file. When a line ID is present and a line color field is not specified, the lines connecting the data points are drawn in a default color.

linecol | The color with which to draw the line; valid values are between 1 and 72 (refer to the symcolor discussion below). If this value varies from point to point (when the points have the same line ID), the line connecting the points is drawn in the color of the first point in the segment (hence, a line may be drawn in multiple colors). |
<table>
<thead>
<tr>
<th>Field Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>radius</strong></td>
<td>Data points with the same line or well ID that have a radius field can have a tube of varying radius (as defined by the values in this field) drawn along the length of the line; this tube is displayed by selecting the Tube Display option on the Render tab.</td>
</tr>
<tr>
<td><strong>dip</strong></td>
<td>The value of the measured dip at that data location; valid values are from 0 to 90; data locations that have associated dip and dip azimuth values have a dipping disk displayed at that location based on the values given.</td>
</tr>
<tr>
<td><strong>dipazm</strong></td>
<td>The compass direction or azimuth of the dip; valid values are from 0 to 360; data locations that have associated dip and dip azimuth values have a dipping disk displayed at that location based on the values given.</td>
</tr>
<tr>
<td><strong>featureid</strong></td>
<td>An alphanumeric description (up to 20 characters), such as “ABC Fault” or “Top Zone”; points with the same value are considered to be along the same feature (such as a fault plane, or located within the same zone); can be used in conjunction with featurecol.</td>
</tr>
<tr>
<td><strong>featurecol</strong></td>
<td>Points that have the same value (1–64) are drawn in the same color (as defined by the feature color table) and are located along the same feature or fault plane (this number could be used to represent any kind of continuous feature); can be used in conjunction with featureid.</td>
</tr>
</tbody>
</table>
| **symbol** | The symbol to draw at the data (X,Y,Z) location; valid values are  
1 = cube [default]  
2 = cross  
3 = diamond  
4 = hourglass  
5 = column  
6 = sphere  
7 = bi-colored sphere or earthquake foci symbol*  
8 = elliptic disk**  
9 = ellipsoid***  
10 = round disk****  
11 = downward-pointing cone  
12 = upward-pointing cone  
* Requires fields TPLUNGE, TAZIM, PPLUNGE, PAZIM, NPLUNGE, and NAZIM; otherwise, the default cube is drawn.  
** Requires fields DIPMIN, DIPAZMMIN, DIPMAX, DIPAZMMAX, AXISLENMIN, AXISLENMAX, DIRECTIONNESS; otherwise, the default cube is drawn.  
*** Requires fields DIPMIN, DIPAZMMIN, DIPMAX, DIPAZMMAX, AXISLENMIN, AXISLENMAX; otherwise, the default cube is drawn.  
**** Drawn at specified DIP and DIPAZM. If DIP and/or DIPAZM are not specified, 0.0 is assumed; if DIP and DIPAZM are present, symbol 10 is assumed, unless another symbol value is specified. |
<p>| <strong>symsize</strong> | Determines the scale factor (or size) with which the symbol is drawn; the default is 1.0; any number between 1 and 100 is valid. |
| <strong>symdatasize</strong> | Although required for the earthquake foci symbol or bi-colored sphere (symbol 7), this field can be applied to any symbol type; it specifies half the width of the symbol in XY (the effective “radius”). For the dip/dipazm disks (symbol #10), it specifies the radius of the disk (regardless of orientation). The radius is specified in data scale units. This field differs from the symradius in that as the Z-exaggeration is increased or decreased, the Z height (as determined by the symdatasize) of the symbol will increase or decrease, respectively; with symradius, the Z height always maintains a proportional size to the XY width. |</p>
<table>
<thead>
<tr>
<th>Field Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>symradius</strong></td>
<td>Similar to symdatasize, the setting specifies half the width of the symbol in XY. For dip/dipazm disks (symbol #10), it specifies the radius of the disk (regardless of orientation). The radius is specified in data scale units. This field differs from the symdatasize in that as the Z-exaggeration is increased or decreased, the Z height of the symbol changes so that it appears to maintain the same proportional size to the XY width.</td>
</tr>
<tr>
<td><strong>symcolor</strong></td>
<td>The color with which the symbol is drawn; valid values are between 1 and 72; the default is white/black (1).</td>
</tr>
<tr>
<td><strong>symtrans</strong></td>
<td>Determines whether the symbol is drawn as a solid object (a value of 0; the default) or if it is drawn transparent (a value of 1).</td>
</tr>
<tr>
<td><strong>zoneid</strong></td>
<td>The alphanumeric ID (up to 20 characters) of the zone where a data point is located in a corresponding EarthVision encrypted faces file. This value is assigned within the EarthVision program.</td>
</tr>
<tr>
<td><strong>zonecol</strong></td>
<td>The assigned color (1–72) of the zone in which the data point is located. This value can be assigned by the user.</td>
</tr>
<tr>
<td><strong>faultblock</strong></td>
<td>The alphanumeric ID of the fault block where a data point is located in a corresponding encrypted faces file. Like the zone ID, this value is assigned within the EarthVision program.</td>
</tr>
<tr>
<td><strong>straight</strong></td>
<td>Determines whether the segment that precedes the current point should be constrained to be straight (nonzero value) or not (0 or blank).</td>
</tr>
<tr>
<td><strong>shotpt</strong></td>
<td>The shotpoint ID (up to 20 characters) for the current point. This field is used in seismic data files. <strong>Earthquake foci symbol additionally recognized field names (SYMBOL field 7 required):</strong></td>
</tr>
<tr>
<td><strong>tplunge</strong></td>
<td>The measured plunge angle of the tensional axis; valid values are 0.0 to 360.0. This field is required for symbol 7 to be drawn.</td>
</tr>
<tr>
<td><strong>tazim</strong></td>
<td>The measured azimuth angle of the tensional axis; valid values are 0.0 to 360.0. This field is required for symbol 7 to be drawn.</td>
</tr>
<tr>
<td>Field Name</td>
<td>Definition</td>
</tr>
<tr>
<td>------------</td>
<td>------------</td>
</tr>
<tr>
<td>pplunge</td>
<td>The measured plunge angle of the compressional axis; valid values are 0.0 to 360.0. This field is required for symbol 7 to be drawn.</td>
</tr>
<tr>
<td>pazim</td>
<td>The measured azimuth angle of the compressional axis; valid values are 0.0 to 360.0. This field is required for symbol 7 to be drawn.</td>
</tr>
<tr>
<td>nplunge</td>
<td>The measured plunge angle of the neutral axis, that is, the axis of intersection of the tensional and compressional axes; valid values are 0.0 to 360.0. This field is required for symbol 7 to be drawn.</td>
</tr>
<tr>
<td>nazim</td>
<td>The measured azimuth angle of the neutral axis, that is, the axis of intersection of the tensional and compressional axes; valid values are 0.0 to 360.0. This field is required for symbol 7 to be drawn.</td>
</tr>
<tr>
<td>symdatasize</td>
<td>Determines the radius of the earthquake foci symbol or bi-colored sphere, symbol 7. Radius is specified in data scale units. This field can be applied to any symbol type; it specifies half the width of the symbol in XY (the effective &quot;radius&quot;). For the dip/dipazm disks (symbol #10), it specifies the radius of the disk (regardless of orientation).</td>
</tr>
<tr>
<td>eqtsymcolor</td>
<td>The color with which to draw the tensional quadrant of the earthquake foci symbol (bi-colored sphere). The default color is blue; valid values are 1 to 72 (refer to symcolor above for available colors).</td>
</tr>
<tr>
<td>eqpsymcolor</td>
<td>The color with which to draw the compressional quadrant of the earthquake foci symbol (bi-colored sphere). The default color is yellow; valid values are 1 to 72 (refer to symcolor above for available colors).</td>
</tr>
<tr>
<td>eqflplane1</td>
<td>Toggles whether or not a fault plane is drawn bisecting the tensional and compressional axes on earthquake foci symbols; valid values are 0 (not drawn) or 1 (drawn).</td>
</tr>
<tr>
<td>eqflplane2</td>
<td>Toggles whether or not a fault plane is drawn whose normal bisects the tensional and compressional axes on earthquake foci symbols; valid values are 0 (not drawn) or 1 (drawn).</td>
</tr>
</tbody>
</table>

**Elliptical and Ellipsoid disk symbol additionally recognized fields names (SYMBOL field 8 or 9, respectively, required):**

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>dipmin</td>
<td>The measured dip angle of the minimum principle axis of symbols 8 or 9; valid values are 0.0 to 360.0. This field is required for symbols 8 or 9 to be drawn.</td>
</tr>
<tr>
<td>dipazmin</td>
<td>The measured dip azimuth of the minimum principle axis of symbols 8 or 9; valid values are 0.0 to 360.0. This field is required for symbols 8 or 9 to be drawn.</td>
</tr>
<tr>
<td>dipmax</td>
<td>The measured dip angle of the maximum principle axis of symbols 8 or 9; valid values are 0.0 to 360.0. This field is required for symbols 8 or 9 to be drawn.</td>
</tr>
</tbody>
</table>
### Field Name Definition

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>dipazmmax</td>
<td>The measured dip azimuth of the maximum principle axis of symbols 8 or 9; valid values are 0.0 to 360.0. This field is required for symbols 8 or 9 to be drawn.</td>
</tr>
<tr>
<td>axislenmin</td>
<td>Determines the radius or length of the minimum principle axis of symbols 8 or 9. Value is specified in data scale units. This field is required for symbols 8 or 9 to be drawn.</td>
</tr>
<tr>
<td>axislenmid</td>
<td>Determines the radius or length of the intermediate principle axis of symbol 8 or 9, an elliptical disk. Value is specified in data scale units. This field is required for symbol 8 or 9 to be drawn.</td>
</tr>
<tr>
<td>axislenmax</td>
<td>Determines the radius or length of the maximum principle axis of symbols 8 or 9. Value is specified in data scale units. This field is required for symbols 8 or 9 to be drawn.</td>
</tr>
<tr>
<td>diskthickness</td>
<td>Determines the thickness of symbol 8, the elliptic disk symbol, in data scale units. This field is required for symbol 8 to be drawn.</td>
</tr>
</tbody>
</table>

### Four coordinate surface additionally recognized field names

The four-coordinate surface is drawn as two triangles composed of vertices (1,2,3) and (2,3,4), which results in a crease occurring between vertices 2 and 3. A special symbol type is not required, but the symbol is drawn if all twelve four-coordinate X,Y,Z values are specified.

| fourc_x1  | Defines the first X, Y, or Z coordinate for four-coordinate surfaces. Specified in data scale units.                                      |
| fourc_y1  |                                                                                                                                 |
| fourc_z1  |                                                                                                                                 |
| fourc_x2  | Defines the second X, Y, or Z coordinate for four-coordinate surfaces. Specified in data scale units.                              |
| fourc_y2  |                                                                                                                                 |
| fourc_z2  |                                                                                                                                 |
| fourc_x3  | Defines the third X, Y, or Z coordinate for four-coordinate surfaces. Specified in data scale units.                             |
| fourc_y3  |                                                                                                                                 |
| fourc_z3  |                                                                                                                                 |
| fourc_x4  | Defines the fourth X, Y, or Z coordinate for four-coordinate surfaces. Specified in data scale units.                            |
| fourc_y4  |                                                                                                                                 |
| fourc_z4  |                                                                                                                                 |

For 3D vector display, fields other than X, Y, and Z must be specified.
For well path files, in addition to X, Y, wellid, symbol, and linecol, the following fields are recognized:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>vec_x1</td>
<td>Specifies the XYZ coordinate (in data scale units) for the tail of the vector.</td>
</tr>
<tr>
<td>vec_y1</td>
<td></td>
</tr>
<tr>
<td>vec_z1</td>
<td></td>
</tr>
<tr>
<td>vec_x2</td>
<td>Specifies the XYZ coordinate (in data scale units) for the head of the vector.</td>
</tr>
<tr>
<td>vec_y2</td>
<td></td>
</tr>
<tr>
<td>vec_z2</td>
<td></td>
</tr>
<tr>
<td>vec_lenpct</td>
<td>Specifies the length of the head as a decimal fraction of total vector length.</td>
</tr>
</tbody>
</table>

Well interpolation fields; these fields are posted by the Demo 3D Viewer and generated as output from other EarthVision modules.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>TVDSS (required)</td>
<td>True vertical depth sub-sea</td>
</tr>
<tr>
<td>Commonid</td>
<td>An additional unique name or a well (20 characters or less)</td>
</tr>
<tr>
<td>MD</td>
<td>Distance measured down the well hole</td>
</tr>
<tr>
<td>AZIMUTH</td>
<td>The angle between the well path and the Y-axis (clockwise)</td>
</tr>
<tr>
<td>INCLINATION</td>
<td>The angle between the well path and a vector pointing straight down</td>
</tr>
<tr>
<td>DELTA_AZIMUTH</td>
<td>The change in azimuth between the current data point in the well path and the previous data point (real)</td>
</tr>
<tr>
<td>DELTA_INCLIN</td>
<td>The change in inclination between the current data point in the well path and the previous data point (real)</td>
</tr>
<tr>
<td>RADIUS_OF_CURV</td>
<td>The radius of curvature is proportional to the reciprocal of the dog-leg severity (real)</td>
</tr>
<tr>
<td>DOGLEG</td>
<td>The dog-leg angle is the angle between the tangent at the point and the tangent at the previous point (real)</td>
</tr>
<tr>
<td>DL_SEVERITY</td>
<td>Dog-leg severity is the number of degrees of dog-leg angle per a distance, typically 30 meters or 100 feet (real)</td>
</tr>
<tr>
<td>ORIG_PT</td>
<td>A flag indicating that the point is an original data point (1) or an interpolated point (0)</td>
</tr>
<tr>
<td>DX</td>
<td>The change in X between the current data point in the well path and the previous data point (real)</td>
</tr>
<tr>
<td>DY</td>
<td>The change in Y between the current data point in the well path and the previous data point (real)</td>
</tr>
<tr>
<td>DZ</td>
<td>The change in Z between the current data point in the well path and the previous data point (real)</td>
</tr>
<tr>
<td>RELATIVE_DIP</td>
<td>The angle between the well path and the normal to the surface (fault or horizon) it intersects</td>
</tr>
</tbody>
</table>
For map pin scattered data files, in addition to linecol and symsize, the following fields are required:

- **pinhead_x**
- **pinhead_y**
- **pinhead_z**
  - Specifies the XYZ coordinate for the head of the map pin

- **pintail_x**
- **pintail_y**
- **pintail_z**
  - Specifies the XYZ coordinate for the tail of the map pin

The following is an excerpt from a map pin file, containing the pinhead XYZ, pintail XYZ, linecol, and symsize fields, and as displayed in the Demo 3D Viewer:

<table>
<thead>
<tr>
<th>pinhead_x</th>
<th>pinhead_y</th>
<th>pinhead_z</th>
<th>pintail_x</th>
<th>pintail_y</th>
<th>pintail_z</th>
<th>linecol</th>
<th>symsize</th>
</tr>
</thead>
<tbody>
<tr>
<td>1823.64080246</td>
<td>2129.84777321</td>
<td>2867.91188094</td>
<td>1824.284</td>
<td>2129.195</td>
<td>2862.776</td>
<td>42</td>
<td>3</td>
</tr>
<tr>
<td>1826.59916022</td>
<td>2130.19176034</td>
<td>2862.56169894</td>
<td>1826.494</td>
<td>2130.354</td>
<td>2862.905</td>
<td>14</td>
<td>3</td>
</tr>
<tr>
<td>1827.69362346</td>
<td>2132.61883908</td>
<td>2870.96323546</td>
<td>1828.705</td>
<td>2131.51</td>
<td>2863.033</td>
<td>42</td>
<td>3</td>
</tr>
<tr>
<td>1828.40298361</td>
<td>2136.97341611</td>
<td>2868.13705263</td>
<td>1830.916</td>
<td>2132.658</td>
<td>2863.155</td>
<td>50</td>
<td>3</td>
</tr>
<tr>
<td>1833.27348966</td>
<td>2133.56098247</td>
<td>2863.0057749</td>
<td>1833.133</td>
<td>2133.802</td>
<td>2863.284</td>
<td>18</td>
<td>3</td>
</tr>
<tr>
<td>1835.4841066</td>
<td>2134.64259301</td>
<td>2863.86382757</td>
<td>1835.355</td>
<td>2134.945</td>
<td>2863.413</td>
<td>34</td>
<td>3</td>
</tr>
<tr>
<td>1833.96311719</td>
<td>2142.81552756</td>
<td>2866.70277956</td>
<td>1837.581</td>
<td>2136.086</td>
<td>2863.543</td>
<td>54</td>
<td>3</td>
</tr>
<tr>
<td>1841.9382564</td>
<td>2132.46416224</td>
<td>2868.71129038</td>
<td>1839.806</td>
<td>2137.222</td>
<td>2863.672</td>
<td>30</td>
<td>3</td>
</tr>
<tr>
<td>1844.84621671</td>
<td>2132.21678005</td>
<td>2868.85792933</td>
<td>1842.032</td>
<td>2138.35</td>
<td>2863.802</td>
<td>30</td>
<td>3</td>
</tr>
<tr>
<td>1847.66978608</td>
<td>2132.37210862</td>
<td>2867.19089623</td>
<td>1844.258</td>
<td>2139.478</td>
<td>2863.931</td>
<td>30</td>
<td>3</td>
</tr>
<tr>
<td>1845.06103278</td>
<td>2142.76879284</td>
<td>2870.26562681</td>
<td>1846.485</td>
<td>2140.604</td>
<td>2864.059</td>
<td>46</td>
<td>3</td>
</tr>
<tr>
<td>1851.79986593</td>
<td>2135.5611788</td>
<td>2864.181</td>
<td>1848.719</td>
<td>2141.724</td>
<td>2864.181</td>
<td>26</td>
<td>3</td>
</tr>
</tbody>
</table>
Vertical Fault Files (.vflt)

Vertical fault files are used for display in the Demo 3D Viewer while viewing a scattered data or an encrypted faces file. Faults can be displayed as lines at the top of the model or as vertical transparent curtains. The display of vertical fault files is controlled by the Render tab; refer to the Render Tab section of this document for more information on posting this file type. Vertical fault files must have names that end with .vflt.

Polygon Files (.ply, .nvflt, .vply)

Polygon files are used strictly for display in the Demo 3D Viewer while viewing a 2D grid, 3D grid, scattered data, or a faces file. These files are displayed as polygons at the top Z-level of the model or as vertical transparent curtains. The display of polygon files is controlled by the Render tab; refer to the Render Tab section of this document for more information on posting this file type. Polygon files must have names that end with .nvflt, .ply, or .vply.

Annotation Files (.ann)

Annotation files are used to display text, lines, symbols, and polygons relative to X,Y locations in the Demo 3D Viewer. Two formats are supported for annotation files: attribute-style annotation and ISM style annotation (Interactive Surface Modeling, Dynamic Graphics' predecessor to EarthVision). The main difference between the two is the method for specifying the annotation parameters (e.g., font, symbol type, color, etc.); however, either format is acceptable for EarthVision. A simple example annotation file is reproduced below.

```
# Type: annotation data
# Version: 76
# Format: free
# Field: 1 x
# Field: 2 y
# Projection: Universal Transverse Mercator
# Zone: 30
# Units: meters
# Ellipsoid: Hayford International 1924
# End:
version 7.0
setatr "Polygon default"
setatr "Polygon boundary default"
srfply
52036.08645762422.353
52027.26485762199.995
52022.8545762088.817
```
Vue Files (.vue,)

Vue files contain a complete definition of the Demo 3D Viewer scene, such as all the displayed models and files, as well as their viewing positions. These specifications include settings such as slice locations, displayed isovalue shells, color files, displayed auxiliary files, even the background color. Vue files allow the user to save a complete set of instructions to, for example, set up a default display of a 3D model or data set, or set up a series of displays. Only those settings specified in a vue file are changed when the file is read.

Vue files are created in the Demo 3D Viewer by selecting File –> Save Vue Display (Ctrl W hot key).

Loading a vue file from previous Demo 3D Viewer versions into the new Demo 3D Viewer results in a warning message. The vue file is loaded, but only relatively simple instructions such as the viewing parameters are read.

Image Registration Files (.imreg)

Image registration files contain information to correlate pixels on a scanned image (various formats, including .jpg, .rgb, .tif) to data scale (i.e., real world) coordinates. An image registration file contains the image file name, and three pairs of data scale coordinates, which are correlated with three pairs of pixel coordinates. Image registration files are used in the Demo 3D Viewer to drape an image on a 3D model or 2D surface.

The image file name must be the first record in the file. Following the image file name is the world XY coordinate and pixel coordinate for each reference point. The origin (0,0) for the pixel coordinate pair is the lower left hand corner. The following is an example of an image registration file:

```
islay.rgb
37916.000000 76250.000000
527 497
42500.000000 77500.000000
516 482
43333.000000 70416.000000
526 429
```
Screen Dump Files (.rgb, .jpg, .bmp, .tiff, and .png)

A computer “picture” of a model display on the screen can be saved to a file by selecting File -> Save Raster Image. This picture is saved to one of several binary file types. The available formats are an SGI .rgb, .gif, .jpeg, .bmp, .tiff or .png. The file can later be displayed on the screen or sent to a printer.

Binary Well Display Files

In order to display well paths, log curves, well-bore annotation, etc. in the Demo 3D Viewer, all parameters for display are specified in a binary well display (.bwd) file created by the Well Display File Editing program. These files include the well path information, display parameters, and a list of the well IDs to be displayed.
Chapter 3: Using the Demo 3D Viewer Interface

The Demo 3D Viewer’s graphical user interface allows users to easily manipulate a 3D model, an ASCII scattered data file or many other file types with ease. This chapter specifically discusses the Demo 3D Viewer interface: what to expect upon entering the Demo 3D Viewer, as well as how to use all aspects of the interface, for example, different mouse button capabilities, usage of menu items, etc. The Demo 3D Viewer has limited functionality compared with the much more capable EarthVision 3D Viewer, the WellArchitect Viewer, and the CoViz 4D Viewer. This documentation covers only the functions available in the Demo 3D Viewer.
Starting the Demo 3D Viewer

The Demo 3D Viewer is started by double-clicking on the *.bat file provided by Dynamic Graphics.

CINDY: edit this: Users will probably start it by double-clicking on a *.bat file that we provide. USGS is likely to provide multiple *.bat files that start it with various files. It isn’t as simple as just double-clicking on the executable because we have to bundle the demoviewern.exe with about 20 other DLLs. So we will tuck it away in a sub-folder and then have the user double-click on it. We could, I suppose designate the name “demoviewern.bat” for the bat file name and then just say that individual distributions may other other launch options.

The Initial Screen Display

Upon entering the Demo 3D Viewer, a File Selection window appears listing all the available encrypted faces files in the current directory that can be displayed in the Demo 3D Viewer. An encrypted faces file must be loaded into the Demo 3D Viewer first, then other file types can be loaded.

A file that is in another directory can be chosen using the controls on the left to navigate to another directory. The Demo 3D Viewer remains in the same directory. To move the Demo 3D Viewer’s working directory to a new directory, select File –> Change Directory.

After selecting an encrypted faces file then clicking the Open button, the selected file is displayed in the Demo 3D Viewer. The Demo 3D Viewer is displayed with a graphic region to the left (also referred to as the Model window) and a Menu Panel window to the right (also referred to as the Panel) by default. The initial screen display contains these main elements:

- The model (the encrypted faces file) presented within the Demo 3D Viewer Model window.
- The Demo 3D Viewer Panel contains a File Selection pane near the top, and a series of tabs below for each of the menus. These menus can be selected by clicking with the left mouse button on the desired menu tab. The Slice tab is selected (i.e., on top of the series of tabs) by default.
- Controls along the margins of the Model window that are used to perform general functions on the Demo 3D Viewer display such as open files, save files, zoom/pan, control file display, and set lighting, among numerous other functions.
- Pull-down menus on the top menu bar of the Model window that include File, Edit, View, Window, Display, Query, Tools, and Help.
Initial Model Display

The initial model shown is the first file that was selected using the File Selection window when entering the Demo 3D Viewer. The default Demo 3D Viewer colors are used for the display. These colors, based on the model's information, can be altered or reversed (e.g., the color that previously represented the highest P-value would then represent the lowest) using functions on the Visible tab.

The X- and Y-axes are labeled on the lower front of the model and the Z-axis is labeled on either the left or right side of the model, whichever is closer to the viewer. The three coordinate axes are highlighted in red, green, and blue respectively.

The model is scaled to fit within the portion of the screen not occupied by the menus. The Z- or vertical-exaggeration is automatically calculated to provide a reasonably proportioned block or wire frame that contains the complete model. (The illustrations on page 14 show the wire frame surrounding the model.) This scaling is necessary since the Z measurement units are often different than those of X and Y. Additionally, it is not unusual for the X- and Y-ranges to be many times greater than the Z-range even when the X- and Y-units and the Z-units are the same. Refer to the Z-Exaggeration section of this document for more information on Z-Exaggeration.

Elevation vs. Depth

The Demo 3D Viewer can display models in either the depth domain (Z increases downward) or elevation domain (Z increases upward). The default Z direction in any one viewing session is decided according to the first data loaded into the Demo 3D Viewer. If the first data are in elevation, then the Demo 3D Viewer session has Z increasing upwards, and vice versa.

If data with the opposite sign convention are introduced later during the session, then the Demo 3D Viewer automatically converts the sign of this new data for display. For example, if depth data are loaded to a Demo 3D Viewer session running in elevation, then the depth data is displayed correctly in the elevation domain. In this way, the Demo 3D Viewer can handle all data irrespective of their vertical coordinate sign convention.

Viewer Z Origin and Z Datum above MSL

Each file loaded to the Demo 3D Viewer environment may be referenced to its own vertical datum; therefore each must be positioned correctly in a vertical sense with respect to all other files. In this regard the Viewer displays two settings: a global “Z Origin,” which determines how the data are viewed (i.e., where is the Viewer’s Z=0 relative to mean sea level) and each file’s “Z datum above Mean Sea Level” (i.e., where the file’s Z=0 is relative to mean sea level).
Z Origin—Viewing Files Relative to any Vertical Datum

In the Viewer (and throughout EarthVision), Z is not required to equal 0 at mean sea level (MSL) (for example, all depths might be relative to a drilling rig or elevations relative to local topography). The “Z Origin,” therefore, sets how Z=0 relates to mean sea level; this is a global parameter meaning it is used throughout the Viewer and is set in terms of elevation above MSL (i.e., if Z=0 is above MSL, the difference is a positive “Z origin”).

Typically, the Z origin is taken from the “Z datum above Mean Sea Level” setting in the first file loaded into the Viewer; if it is not set in the file, or is undefined, the Z Origin is set to 0 (i.e., MSL).

The current setting of the Z Origin is shown alongside the onscreen 3D compass, if the Z Origin is not 0, i.e., the Z Origin is not mean sea level. (Refer to the sections below for more details on these features).

Z Datum Above MSL—File-specific Vertical Reference

“Z datum above MSL” is a file-specific setting. It specifies the vertical datum from which all Z values in that file are referenced (i.e. the elevation above MSL where Z = 0 in a specific file). In other words, the Z values in any file are not required to be measured from MSL; they could be measured from a Kelly Bushing (KB), a seismic datum, or some other non-MSL datum. Files with multiple different Z datums can be loaded and displayed simultaneously in the Demo 3D Viewer, and are automatically corrected for their different datum values so that the relative Z values are correct.

For a full discussion of these file settings and Viewer behavior, see Appendix A: Shared Components and Conventions.

Vue File Usage to Change the Initial Model Display

A file containing default positions for a particular faces file, grid file, or ASCII scattered data file can be created inside or outside of the Demo 3D Viewer for display inside the Demo 3D Viewer. These files, called “vue” files, are used to automatically load custom settings for the initial model display, i.e., set up the initial view of the file. The file consists of keywords followed by parameters (e.g., a keyword for the azimuth, followed by the value of the azimuth). The file is ASCII, with each keyword and parameter on one line, separated from others by a carriage return.
## File Pull-down Menu

The File pull-down menu contains the following functions:

- **Open**........................ loads an existing file into the Demo 3D Viewer using a File Selection window. See File Selection Window for more information.

- **Copy**.......................... copies the currently active file to a user-specified file name.

- **Remove**....................... produces a window listing the files currently in the Demo 3D Viewer; a file or group of files other than the encrypted faces file can be selected and removed from the Demo 3D Viewer. Once loaded, the encrypted faces file can not be removed from the Demo 3D Viewer.

- **Load Vue** ..................... contains three options: Load Vue produces a File Selection window displaying the vue (.vue) files in the current folder or working directory; the selected vue file is loaded into the Demo 3D Viewer; Load Recent Vue lists the ten most recently used vue files or vue frames for loading; Viewing Parameters Only loads only the viewing parameters (e.g., inclination, azimuth, lighting parameters) from a specified vue file (selected via a File Selection window). See Vue Files for more information.

- **Save Display to Vue** ........ saves the current display settings as a vue (.vue) file.

- **Save Raster Image** ........... produces an Image Capture window from which an output of the Model window image (without the tool bars, etc.) can be generated. The image size (i.e., actual window size, user defined pixel size, or maximum resolution), image file format (i.e., TIFF, RGB, JPEG, or BMP), and file name are specified. An image format quality of Basic (60% quality), Normal (80% quality) or Fine (95% quality) is specified for JPEG files.

- **Copy Image to Clipboard** ... copies the current Model window image to the computer clipboard so that it can then be pasted into any program that accesses the clipboard.

<table>
<thead>
<tr>
<th>File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
</tr>
<tr>
<td>New</td>
</tr>
<tr>
<td>Copy</td>
</tr>
<tr>
<td>Save edited file(s)</td>
</tr>
<tr>
<td>Save edited file(s) As</td>
</tr>
<tr>
<td>Remove...</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Load vue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save vue display... Ctrl+H</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Load Raster Image...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load Raster Image to clipboard</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Change directory...</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Exit</th>
</tr>
</thead>
</table>

| Ctrl+HQ |
• Change Directory produces a File Selection window, from which an existing directory can be selected or a new directory created (Microsoft Windows only).

• Exit exits the Demo 3D Viewer, closing the Model and Panel windows.

File Selection Window

Selecting File -> Open -> “file type” produces a File Selection window, shown below, in which a file can be selected. After selecting a file(s), select the Open button to display the file in the Viewer.

In the Demo 3D Viewer, the Statistics, Header, View, Graphic Edit, and Text Edit buttons at the bottom of the window are inactive.
Edit Pull-down Menu

Selecting Edit -> Preferences produces a Preferences window, shown below, used to establish settings (e.g., the current window geometry) that are applied every time the Demo 3D Viewer program is started.

![Preferences Window](image)

The Preferences window contains the following tabs:

- **Window** sets preferences for the Demo 3D Viewer display window. The window layout can be saved explicitly or continuously, as specified in Save Window Layout. *Explicitly* means save the window layout right now, but only once, when the Save Now button is selected. *Whenever Exiting* means that the window layout is automatically saved every time the user exits the Demo 3D Viewer. The 3D Window Toolbars checkbox sets whether or not toolbars are displayed for the Demo 3D Viewer. The Keep Backgnd Color checkbox specifies whether the current settings for black/white reversal are saved and used each time the Demo 3D Viewer is entered. The Panel layout can be set such that the File Selection pane is either above the tabbed menus (by selecting the Vertical radio button) or to the side of the tabbed menus (by selecting the Horizontal radio button). If set to Horizontal, the File Selection on Left checkbox controls whether the File Selection pane is to the left or the right of the tabbed menus.
- Render. . . . . . . . . sets preferences for point rendering, lighting and display lists. The **Point Rendering Count** is the number of points above which data points are displayed as single pixel points, rather than resizable cubes. The **Default Symbol Scale** controls the relative scale for symbols. The **Mouse Drag Time Limit** is the time limit beyond which, when dragging the model with the mouse, a simpler line rendering model is used; that is, models, grids, etc., are displayed as wireframes rather than fully rendering the data during rotation. The **Annotation Drape Resolution** sets the pixel resolution for draping annotation. Setting the resolution lower results in faster rendering; the resolutions are 1024, 2048, and 4096 pixels. A higher amount results in finer detail, but increased render time; a smaller amount results in coarser detail, but faster render times. Annotation draping at high resolution may be unpredictable when used on computers with less powerful graphics boards. If the annotation draping results in the Viewer look erroneous, decrease the **Annotation Drape Resolution** and try again. The **Apply Point Render to Ellipsoids/Ellipses** checkbox controls whether or not those symbol types are displayed as points or as ellipsoids/disks when point rendering is turned on. The **Save Current Lighting** checkbox controls whether the current lighting parameters are saved and used each time the Demo 3D Viewer is entered. The **Use OpenGL Display Lists If Available** checkbox controls whether display lists are used for rendering some model types which may render faster. Also note the 4dv files will occupy a lot more system RAM when the OpenGL Display lists are in use. The **Always Disable Immediate Sliders at Startup** checkbox controls whether the **Immediate Slider Update** icon is enabled or disabled. On program startup, the initial setting for the **Immediate Slider Update** icon considers the current rendering performance.

3D grid optimization threshold. The defaults for this user-adjustable option are 150 Mb on 32-bit OS, and 500 Mb for 64-bit OS. 3D grids occupy a lot of system memory and can cause problem on systems with limited RAM. Hence addition memory savings routines (with the minor performance impact) take effect when loading 3D grids above this file size.

- File. . . . . . . . . . sets preferences for file updating and vue errors. The **Ignore Vue/vlist Errors** setting determines if any errors encountered when a vue file is loaded (e.g., a file is missing from the specified directory) should be displayed in a pop-up window (the default setting is off) or not (the checkbox should be set on). The **File Updating section**
controls whether files loaded in the Demo 3D Viewer are potentially updated if the files are changed on disk. The selections are Ask Before Updating or Never Update. The Update Frequency is specified in seconds.

- **Attribute**... sets preferences for attribute color tables and multiple Z fields. The Share Color Tables for Discrete Attributes specifies whether colors are automatically shared between two or more files that have discrete attributes with the same field name. The Share Color Tables for Numeric Attributes specifies whether colors are automatically shared between two or more files that have numeric attributes with the same field name. The Scattered Data option on this tab allows the user to always load the file with the attribute called “z” as the vertical coordinate. If this option is not selected, and if the file contains more than one field that might represent the vertical coordinate, then a pop-up menu appears while the file is loading, giving the user the option to select which field represents the vertical dimension. The Max discrete attribute checkboxes sets the maximum number of discrete attributes viewable on the Visible tab. The default is 2000.

Preferences are saved in $HOME/.evview/evview.pref. If a file is found in $COVIZHOME/etc/evview.pref, it is loaded first, and then $HOME/.evview/evview.pref is loaded.

The Restore Default, OK, and Cancel buttons function the same for all the tabs. Selecting Restore Default sets the preferences to their default values for all tabs, regardless of what tab is currently displayed. Selecting OK saves the currently set preferences and closes the Preferences window. Selecting Cancel closes the Preferences window without applying any preference changes.

### View Pull-down Menu

The functions on the View pull-down menu that are available in the Demo 3D Viewer are discussed below.
View → Lighting

Selecting View → Lighting produces a Lighting Control window, shown below, that is used to set various lighting parameters for the Model window. Lighting parameters include the following:

- **Scene Ambience**
  
  Ambient light is a non-directional light source meaning that it illuminates the model equally from all directions. Ambient light is also reflected equally in all directions. The effect on the model is independent of the position of the model and the orientation of the eye. The default Scene Ambience value is 0.3, on an arbitrary scale of 0 to 1. Moving the slider handle to the right, thus increasing the scene ambience, creates a highly lit, paler scene. Decreasing the scene ambience (moving the handle to the left) creates a darker, richer scene. In addition, a value can be entered directly by clicking with the left mouse button on the value box and entering in the desired value.

- **Material Specularity**
  
  Specularity describes to what degree the directional light is reflected by the 3D model. The reflected light tends to give the surfaces a three-dimensional quality, although in
In some cases the user may want to change the reflectivity (e.g., when a slice is pointed directly at the eye point, a high value for the material specularity causes the face to appear white).

When a surface reflects 0% of the directional light, the model appears to have a matte surface. No directional light is reflected back to the user; therefore, no highlights are seen on the model. This type of matte surface is sometimes desirable when highlights obscure details of the model.

When a surface reflects 100% of the directional light, the user sees reflected highlights on the surface of the model, depending upon the model, the position of the light source, and the angle of view. A highly specular surface produces highlights that can add realism to a 3D model.

The default setting for the material specularity is 0.5 (the median amount of reflective light). Changing this setting decreases the reflectivity of the model, with a setting of 0 indicating 0% reflected light. In addition, a value can be entered directly by clicking with the left mouse button on the value box and entering in the desired value.

- **Light Source Intensity** controls the brightness or intensity of the light source. The range is from 0 (less intense) to 1 (most intense), with a default of 1. In addition, a value can be entered directly by clicking with the left mouse button on the value box and entering in the desired value.

- **Light Source Azimuth** The heading or direction in the horizontal plane from the eye point to the look point (generally the center of the model), where 0.0 is looking from the user towards the workstation. The permissible range is from -90 to +90, with a default of 0. Changing the inclination and azimuth of the light source changes how the user views the model, what parts of the model are illuminated, how much light is reflected back toward the eye point, etc. When the azimuth and inclination are both at 0, the light sources are directly behind the eye point.

- **Light Source Inclination** The angle above the horizon or horizontal plane that includes the eye point and the look point, measured as degrees. The permissible range is from -90 to +90, with a
default of 0. Changing the inclination and azimuth of the light source changes how the user views the model, what parts of the model are illuminated, how much light is reflected back toward the eye point, etc. When the azimuth and inclination are both at 0, the light sources are directly behind the eye point.

- **Use Second Light Source** controls whether one or two directional light sources are used. By default only one light source is on. When this checkbox is checked, a second light source illuminates the model and the second set of lighting controls becomes active.

- **Defer Update** delays a redraw of the Demo 3D Viewer display lighting until either the *Update Scene* or the OK button is selected. That way multiple changes can be made to the lighting before the image is redrawn.

- **Update Scene** immediately redraws the Demo 3D Viewer display with the new lighting parameters.
View → Axes and Labels

Selecting View → Axes and Labels produces the Axes Control window, shown below, in which axes and label posting parameters are specified. Axes and labels controls include:

- **Axes**. Checking the Axes checkbox displays the axes lines; unchecking the checkbox means that axes lines are not displayed.
- **Axes Pixel Width**. Select the axes line pixel width. The default is 1 pixel. If there is more than one model space in the Viewer, this setting will affect all model spaces.
- **Color**. Select the color for axes lines, labels, and captions. A color palette is displayed, from which a color can be selected or custom colors can be created.
• Labels ................. checking the Labels checkbox displays the axes labels; un-checking the checkbox means that axes labels are not displayed.

• Labels Pixel Width ...... select the axes label pixel width. The default is 1 pixel. A larger pixel width results in bolder labels. If there is more than one model space in the Viewer, this setting will affect all model spaces.

• Size .................... select the size of the axes labels and captions. Size is relative, for example, a size of 2 is larger than a size of 1.

• North Arrow .............. checking the North Arrow checkbox displays the North arrow; un-checking the checkbox means that no North arrow is displayed.

• North Arrow Position ...... select the North Arrow position, either at the Zmin or Zmax of the model.

• Scale Bar ................. checking the Visible checkbox displays a scale bar; un-checking the checkbox means that no scale bar is displayed.

• Tickmark Intervals ........ specify the interval between adjacent X, Y, and Z tickmarks.

• Tickmark Reference ........ specify the reference value from which the X, Y, and Z tickmarks are calculated.

• Captions ................. specify captions for the X, Y, and Z axes.

The Lattice tab, shown below, controls the display of wireframe measurement tick mark lattices along each of the axis planes.
- **Space Selection** ........ the space selection can not be changed because the Demo 3D Viewer uses only a single space.

- **Lattice Visibilities** ........ The six lattice planes can have their visibilities controlled independently using these settings. Also, the three “front” or “back” lattices can be toggled on or off simultaneously using the appropriate buttons. The notion of 3D “front” and “back” will adapt as the 3D visualization is rotated unless the lock icon is depressed, in which case the “front” and “back” lattices are frozen to their current positions.

- **Lattice Positions** ........ the X-axis, Y-axis, and Z-axis scroll bars are used to specify the exact X, Y, and/or Z location for the lattices.

- **Lattice Line Width** ........ specify the line width for the lattice. The options are 1 (the default), 2, 3, or 4. A smaller number is a thinner line width; a larger number is the thicker line width.
- Snap to Ticks: selecting this option will ensure that the lattice panels are always aligned with a major tick mark on the axes.
- Reset: selecting this option resets the lattice positions back to the default.

### Window Pull-down Menu

The Window pull-down menu contains the following functions:

<table>
<thead>
<tr>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>New View</td>
</tr>
<tr>
<td>Close view</td>
</tr>
<tr>
<td>Reset window geometries</td>
</tr>
<tr>
<td>Toolbars</td>
</tr>
<tr>
<td>Double buffer mode</td>
</tr>
<tr>
<td>Reverse black/white</td>
</tr>
<tr>
<td>Set background color...</td>
</tr>
</tbody>
</table>

- **New View**: duplicates the current Model window as it is currently displayed. A new Model window appears, sized approximately 25% the size of the original Model window. When a file is added to one Model window, it also shows up in all other Model windows. The same is true for color tables: when the color table is changed in one Model window, it changes in all Model windows. Some parameters may vary among different Model windows: the viewing parameters, mostly represented by the thumbwheels (i.e., azimuth, inclination, lookpoint, zoom), and the vertical toolbar icon settings (i.e., pointer mode, magnifier, double buffering, perspective viewing).

- **Reset Window Geometries**: resets the Model window geometry, such as size and position on the monitor screen, to its original, default geometry.

- **Toolbars**: toggles the display of the toolbars surrounding all four sides of the Model window. By default, they are displayed.

- **Double Buffer Mode**: toggles between single and double buffer modes. By default, the files shown on the Model window are drawn in double buffer mode, except on 8-bit color workstations. Double buffer mode means that if any changes are made to the display (for example, changing the azimuth or bringing in a new file), the new display is drawn in the background (in the back buffer) until it is complete. Once complete, it is brought to the foreground (the front buffer), so the user can see the display.

Sometimes it is useful to see the display while it is drawing: to view the interior of a model, or, if the model takes a long time to redraw, to monitor its progress. To view the redraw,
double buffer mode must be turned off (putting the display in what is known as single buffer mode). Double buffer mode is on by default.

- **Reverse Black/White** switches the default black background color to white and the default white foreground color to black. This is useful when a screen image is being sent to a printer. In addition, data points and screen annotation having a white color are also swapped to black. Holding down the **Ctrl** key while left-clicking on the **Reverse Black/White** icon button cycles through five shades of gray.

- **Set Background Color** brings up a color palette from which a color can be selected to use as the background color for the Model window (by default, the background color is black). Custom colors may also be created.

**Note:** Sometimes a redraw must be forced to see the background color change. To do so, rotate the scene slightly.

### Display Pull-down Menu

The files loaded into the Demo 3D Viewer are displayed within a wire frame, known as the axes, with tick marks and labels displayed along the three axes closest to the front of the screen. A compass appears in the lower left corner of the screen to orient the Demo 3D Viewer. The commands on the Display pull-down menu control the display (on/off) of the axes, labels, 3D Cursor, color key, and compass. The Display pull-down menu contains the following selections:

- **Axes** turns the model wire frame or axes on or off. By default, the axes are displayed.

- **Labels** turns on or off the tick marks and numeric labels along the axes. The display of the labels and tick marks is, therefore, independent of the axes display. By default, the labels and tick marks are on.

- **3D Cursor** turns the 3D Cursor on or off. By default, the cursor is off. See *The Demo 3D Viewer Cursor* for more information.

- **Color Key(s)** turns on/off any Color Keys displayed. By default, the Color Key for the active file’s attribute (by which the file is colored) is displayed in the upper left-hand corner of the
Model window. Multiple Color Keys can be displayed simultaneously by right-clicking on the current color key, then selecting New from the pop-up menu that appears. Additional items on the pop-up menu are: Show (when set off, the Display –> Color Key(s) function is used to turn it (them) back on), Lock (locks the current color table to this configuration), Remove, and Font Sizes (controls font size for the color key).

- Compass . . . . . . . . . . . . . . . . . . . . . turns on/off the X, Y, Z compass (i.e., axis orientation diagram). By default the compass appears in the lower left corner of the Model window; the compass can be dragged to a new location using the left mouse button (the mouse cursor changes to a cross bar when positioned for dragging). The compass shows the current direction of the principle X, Y, and Z axes (joining at the minimum X, Y, and Z point). The three principle axes of the model's wire frame correspond to the orientation diagram and are drawn in the same color (i.e., the X axis is red, Y axis is yellow, and Z axis is blue). The axis orientation diagram rotates with model rotation. Right clicking on the compass rose within the Demo 3D Viewer brings up additional options to control the size of the compass on-screen, and the option to display the Viewer space “Z origin” setting beneath the compass on-screen.

Query Pull-down Menu

There are no functions available on the Query pull-down menu in the Demo 3D Viewer.

Tools Pull-down Menu

There are no functions available on the Tools pull-down menu in the Demo 3D Viewer.
Help Pull-down Menu

Various types of help are available for assistance in running the Demo Viewer. In addition to these menu options, "ToolTip" help is also available for specific tools and icons. Hover the mouse pointer above the tool of interest, and the help appears in a small box.

- **Documentation** ................. Displays the Demo 3D Viewer documentation
- **Keyboard Shortcuts** .......... Displays a list of the Demo Viewer hotkeys or keyboard shortcuts.
- **What’s New** ................. Displays a list of the latest 3D program changes.
- **About the EarthVision Demo** ...... Displays the version number, date, and licensing information for the Demo 3D Viewer, and contact information for Dynamic Graphics.

Icon Buttons Around the Model Window

The numerous icon buttons around the perimeter of the Demo 3D Viewer Model window are used to maneuver, manipulate, and edit in the Demo 3D Viewer. Positioning the mouse cursor over an icon button produces tool-tips that describes the icon button function. Each of the icon buttons are described in the sections that follow.

The following diagram is a quick reference showing the icon buttons and the button names. Not all icon buttons are active in the Demo 3D Viewer, but they are displayed on the following diagram for reference purposes.
Open

Selecting the Open (load a file) icon button produces a File Selection window listing all of the file types that can be loaded into the Demo 3D Viewer (e.g., models, data, images, and vue files). A single file is selected by clicking on it with the left mouse button. Multiple files are selected by holding down the Ctrl key while selecting various file names. A series of consecutive files are selected by holding down the Shift key while selecting the first file and the last file; the first file, the last file, and all the files in between the two are automatically selected. The selected files are loaded into the Demo 3D Viewer display. Selecting the Open icon button has the same effect as selecting File -> Open.

3D Cursor

Selecting the 3D Cursor icon button (or the Ctrl+K hot key) displays a 3D cursor in the Model window. The 3D Cursor can then be used for snapping to a point or location (discussed next). The X/Y/Z location of the 3D Cursor is always displayed at the bottom of the Model window on the right hand side; the location includes the X, Y, and Z units, and also if the model space is upwards (in elevation; Z increases upwards) or downwards (in depth; Z increases downwards).
3D Cursor Positioning and Measurement

Selecting the 3D Cursor Positioning and Measurement icon button displays a 3D Cursor in the Model window, if one is not already there, and produces a 3D Cursor Dialog window, shown below. The following tabs are in the 3D Cursor Dialog window, and each is discussed below:

- **Location** controls the 3D cursor location, display, and measurement
- **Options** controls the X, Y, and Z scale bar interval, whether the 3D cursor is subdivided and/or shaded, and the pixel width of the cursor. The scale bar XY and Z intervals specified here also determine the interval by which the cursor moves when using the arrows on the Location tab.
Location Tab

The following controls are on the Location tab:

- **X-, Y-, and Z-axis Locations** - the exact X, Y, Z location of the 3D cursor can be specified using the slider bars or by entering the exact location.

- **3D Cursor Planes** - the 3D cursor X, Y, and Z axes can be displayed either as lines (the default) or as transparent planes. When planes are on, the cursor location can be changed by clicking or dragging on any part of an exposed plane; when the axes are displayed, clicking on any axis moves the 3D Cursor to that location.

- **3D Cursor Marks** - selecting the Add button adds another 3D Cursor at the current location and adds a line to the 3D Cursor table immediately below. The new cursor will not be visible until it is moved to a new location. Selecting the Delete button deletes the 3D Cursor that is highlighted in the 3D Cursor table. 3D Cursors are displayed in unique colors to distinguish one from another. The first 3D Cursor is red, the second is yellow, the third is green, and clicking on the color button allows you to select a cursor color. A red outline surrounds the active cursor's text box (e.g., Cursor 1 or Cursor 2) and, in the Model window, cross hairs appear extending from that cursor, while the other cursor mark does not have cross hairs.

- **Mode** - selecting History displays the most recent 3D cursor location in red with previous locations in black. Selecting Measure calculates measurements between two or three 3D cursor locations; which cursor locations are used is set by clicking the Measure (the green ruler) icon in. Selecting Current Locations displays only the X, Y, Z locations of each 3D cursor.

- **Clear** - clears the columns of 3D cursor values.

- **Copy** - copies the columns of 3D cursor values to the system clipboard, for use in any program that can paste from a clipboard.

- **Save** - saves the history of current 3D cursor locations to a user-specified scattered data file and loads this file into the Demo 3D Viewer.
Options Tab

The following controls are on the Options tab:

- **Scalebar Interval**. By default, the axes of the 3D cursor are shown as scaled lines, in alternating colored and white line segments and the Demo 3D Viewer selects a line segment length that varies automatically as the view is zoomed in or out. No matter how far in or out the view is, the scalebars are divided into a reasonable number of sections. The line segment length can be changed, however, to user-specified values. When a specific interval length is entered, the line segments do not change when the view is zoomed. In addition, regardless of how these values are set, the XY and Z values also control the intervals that the arrow buttons change the 3D Cursor location for the sliders on the Location tab.

- **Cursor Object**. Controls whether the active 3D cursor is subdivided and/or shaded, and the pixel width of the cursor.

- **Cursor Sphere**. Controls whether a sphere is displayed around the active 3D cursor. The sphere is constant radius, expressed in XY units, and will stretch when the Z-exaggeration is not 1. The sphere can be transparent or opaque, as controlled by the Transparency checkbox.

Measure Using Two 3D Cursors

One of the functions of the 3D Cursor is to measure between two points or calculate the area of a triangle between three points. For example, a measurement can be calculated between a tops pick and the surface grid. This can be done by selecting the 3D Cursor Snapping icon button (sixth button on the top tool bar), clicking anywhere on the gridded surface; notice that the 3D Cursor moves to the selected point. You can also click and drag the 3D Cursor over the gridded surface. In the 3D Cursor dialog window, selecting the **Add** button in the 3D Cursor Marks section adds a second 3D Cursor. In the 3D Cursor dialog, setting the Mode combo box to Measure then selecting the Measure (i.e., the green ruler) icon buttons for both Cursor 1 and Cursor 2, calculates the distance between the two cursor locations in data scale units, along with the plunge and bearing.

Calculate Area Using Three 3D Cursors

Area can be calculated between three 3D cursors, provided that they form a triangle. Selecting the Measure (green ruler) icon button displays a yellow triangle connecting the three 3D cursor locations, and
the plane dip, plane dip-azimuth, and area are calculated and displayed near the bottom of the 3D Cursor Dialog window.

Setting the Mode to Current Locations displays the current X, Y, Z location of each 3D cursor near the bottom of the window. Selecting the bottom icon button, Save Current History of Scattered Data Locations to Scattered Data File, creates a scattered data file containing the 3D cursor locations.

### 3D Cursor Snapping

Selecting the 3D Cursor Snapping icon button immediately moves the 3D cursor to the location the user clicks on. An additional way of snapping the cursor to a scattered data point (without turning on snap-to-surface) is to first pick a point, then press the J hot key, which is the hot key for the Snap to Last Picked Point function.

The 3D Cursor can also be snapped to a surface. For example, say that a proposed well is displayed with a surface or set of surfaces, it is often useful to move—or “snap”—a proposed well location to the closest surface or location on an image plane (i.e., the X, Y, or Z plane on which an image is displayed).

### Set Lighting

The Set Lighting icon button is used to specify lighting parameters. This icon button functions the same way as selecting View -> Lighting. Refer to Lighting for more information.

### Set Axes, Labels, and Captions

Selecting the Set Axes, Labels, and Captions icon button produces an Axes Dialog window, shown below, that is used to specify details for axes posting, labeling, tickmark reference and intervals, and captions. The Lattice tab on the same interface provides control over the rendering of the wireframe measurement lattice. Refer to the View -> Axes and Labels section for more information.
Demo 3D Viewer Mouse Pointer

The Demo 3D Viewer mouse pointer can take on several forms; each of these forms indicates a different state or mode to the user. Most of the time, the pointer is in the shape of a hand or left-slanting arrow. Each of the shapes are described below:

- **Left-slanting arrow** . . . . . . referred to as *Select* mode, this pointer is used for scattered data picking, snap to object, screen annotation, and user input. The *tab* hot key switches the pointer between the *Select* and *Manipulate* modes.

- **Hand** . . . . . . . . . . referred to as *Manipulate* mode, this cursor is used to rotate, zoom, and pan, to work with the 3D Cursor, and to slice along the X, Y, or Z
The mouse pointer shape changes to an arrow with a small + sign when the mouse pointer is very near one of the 3D Cursor axes. This lets the user know that if they then click down, the 3D Cursor will change locations.

Controls in the Panel can be selected in either Select mode or Manipulate mode. The tab hot key alternates between the Select and Manipulate modes. In either Select or Manipulate mode, the mouse pointer shape changes to an arrow with a small + sign when the mouse pointer is very near one of the 3D Cursor axes. This lets the user know that if they then click down, the 3D Cursor will change locations.

Select Mode

In the Demo 3D Viewer, the mouse pointer changes depending upon the current mode. Clicking the Select Mode icon button produces a left-facing arrow mouse pointer. This mouse pointer is used for scattered data picking, snapping to an object, and user input. Refer to File Query for more information on querying files when using Select mode.
Manipulate Mode

In the Demo 3D Viewer, the cursor is either a left facing arrow or a hand. Selecting the Manipulate Mode icon button produces a hand cursor. This cursor is used to rotate, zoom, and pan, to work with the 3D Cursor, and to slice along the X, Y, or Z plane. The tab hot key alternates between the Select and Manipulate modes.

In either Manipulate or Select mode, the mouse pointer shape changes to an arrow with a small + sign when the mouse pointer is very near one of the 3D Cursor axes. This lets the user know that if they then click down, the 3D Cursor will change locations.

Screen Annotation Edit

Selecting the Screen Annotation Edit icon button allows the creation and editing of screen annotation such as text, vectors, and pencil lines. If displayed, screen annotation is saved to a vue file when a vue file is saved.

To select or edit screen annotation, select the Screen Annotation Edit icon button. When in Annotation Edit mode, the icons on the vertical and horizontal tool bars change, and the mouse pointer varies between four modes: vector, text, pencil, and screen annotation move/edit.

The following screen annotation icon buttons are arranged vertically along the side of the Model window:

- 2D Vector . . . . . . . . . . . . . . . . . . selecting the 2D Vector icon button creates a 2D vector, with an arrow at the end of the vector. The left mouse button is used to press and sweep a 2D vector. When the 2D Vector icon button is active, a Pixels pull-down menu (discussed below) appears along the horizontal toolbar of the Model window.

- Text . . . . . . . . . . . . . . . . . . . . . . . . selecting the Text icon button creates text in the Model window. Click the left mouse button in the window to locate the text; click a second time and begin typing the desired text. Pressing the Return key adds another line of text. Clicking with the mouse elsewhere in the Model window, or on a button adds more text in the selected location. When the Text icon button is active, the controls (discussed below) appear along the horizontal toolbar of the Model window.

- Continuous Pencil Line . . . . . . . . . . selecting the Continuous Pencil Line icon button creates a continuous line. The left mouse button is used to press and
draw the continuous line, then release the left mouse button to end the line. When the Continuous Pencil Line icon button is active, a pull-down menu (discussed below) appears along the horizontal toolbar of the Model window to specify the pixel width of the pencil line.

- **Delete and Move Annotation** . . . . . . selecting the Delete and Move Annotation icon button either deletes the selected screen annotation or moves it from one location to another. To delete screen annotation, first select the Delete and Move Annotation icon button, then use the left mouse button to select the annotation, and click the Delete key on the keyboard. To move screen annotation, first select the Delete and Move Annotation icon button, then position the cursor over the annotation, press and hold the left mouse button, drag the annotation to its new location, and release the mouse button.

- **Lock icon/Retain Annotation** . . . . . selecting the Retain Annotation After View Change icon button (the lock symbol) locks the screen annotation in place, so that when the model is manipulated (e.g., rotate, zoom/pan) the annotation stays in the same place. Unlocking the screen annotation causes the annotation to disappear whenever the model is manipulated. Screen annotation is unlocked by default.

- **Clear Any Screen Annotation** . . . . . selecting the Clear Any Screen Annotation icon button removes all currently displayed screen annotation.

The following screen annotation icon buttons are arranged horizontally along the top of the Model window:

- **Color Palette** . . . . . . . . . . . . . . . . . . selecting the Color Palette icon button produces a color window in which basic colors can be selected or custom colors blended. A color is selected for the next annotation to be created. The default color is white/black. The Color Palette icon is available for all screen annotation types.

- **Pixels** . . . . . . . . . . . . . . . . . the Pixels pull-down menu specifies the pixel width of screen annotation vectors and pencil lines. The range is 1 to 5 pixels; the default is 2 pixels. The Pixels menu is available for vectors and pencil lines.
• **Font Type**... sets the font type for the text that is created. The available fonts are: Arial (the default), Courier New, Century School-book, and Times New Roman. This item only appears when text is being created. The font types available on Linux are: Helvetica (default), Courier, New Century Schoolbook, and Times New Roman.

• **Font Size**... sets the font size for the text that is created. The available font sizes are: 8, 10, 12, 14, 16, 18, 20, 24, and 32. This item only appears when text is being created. The font sizes available on Linux are 8, 10, 12, 14, 18, and 24.

• **Bold, Italic, and Underline**... sets whether the text that is created should be plain text (the default) or bold, italic, and/or underlined. These items only appear when text is being created.

---

**Centering Tool**

Selecting the **Centering Tool** icon button then clicking on a surface or point centers the look point (the X,Y,Z location that is used as the rotation point for the model) on that surface or point. By default, the look point is at the center of the model (half-way along the X, Y, and Z axes). The look point is always placed in the middle of the Model window, regardless of its location within the model.

Changing the look point results in essentially a panning of the model. It is especially useful when a user wants to zoom in on particular area. For example, if the area of interest is near an outer edge, as the zoom distance is decreased (zooming in), the area may disappear off the screen. Moving the look point closer to the area of interest repositions that area to the center of the screen.

The look point can be returned to the center of the model by clicking on the **Reset Look Point** (home) icon button near the Pan thumbwheels.

---

**Reset View**

Selecting the **Reset View** icon button resets the Model window to the default settings.
Magnifier Tool

Selecting the Magnifier Tool icon button changes the shape of the mouse cursor; clicking the mouse cursor in the Model window turns on a magnifying glass. The magnifier window can be moved about the Model window by dragging the window using the left mouse button. Placing the left mouse button on the edge of the magnifier window and dragging it, increases or decreases the magnified region. The magnification can be changed using the middle mouse button to zoom in or out. The magnifier can be turned off either via the Magnifier Tool icon button or using the right mouse button to bring up a pop-up menu.

Reverse Background Black/White

Selecting the Reverse Background Black/White icon button toggles the color of the background between black and white. Holding down the Ctrl key while left-clicking on the Reverse Background Black/White icon button cycles through five shades of gray. As the background color changes, the color of the axes lines, ticks, and labels change as well.

Perspective/Orthographic

Selecting the Perspective/Orthographic icon button toggles between the two types of projection available for viewing the current display: a perspective projection or an orthographic projection. By default, the model is displayed with the perspective projection.

The perspective projection causes the model to look more realistic because objects that are farther away appear smaller than objects that are closer. The “parallel” lines of the wire frame (the axes), although they appear parallel, actually converge at some distant point behind the model.

When the perspective projection is off, orthographic projection is used. This projection draws all objects of the same dimensions at the same size regardless of the distance from the eye point. In this case, the “parallel” lines of the wire frame are truly parallel on the screen.
Inclination

Pressing and holding the Inclination thumbwheel with the left mouse button, rolling it down rotates the top face of the model down, thereby increasing the inclination. This has the same effect as typing the down arrow button on the keyboard. Rolling the thumbwheel up rotates the top face of the model up, thereby decreasing the inclination. This has the same effect as typing the up arrow key on the keyboard. When the inclination equals 90, the maximum Z-plane is facing forward, and an inclination of -90 faces the minimum Z-plane forward. The inclination can be set to a specific value by clicking with the left mouse button on the value box below the thumbwheel and typing in the new, desired inclination. The smallest increment for the value box is 0.1. The smallest increment for the thumbwheel is 0.5. The default inclination is 35.

Azimuth

Pressing and holding the Azimuth thumbwheel with the left mouse button, rolling it to the left decreases the azimuth, rotating the model to the left or clockwise if looking down from above the model. It has the same effect as the left arrow key on the keyboard. Moving the thumbwheel to the right rotates the model counter-clockwise (again while looking down from above the model). It has the same effect as the right arrow key on the keyboard. The azimuth can be set to a specific value by clicking with the left mouse button on the value box to the right of the thumbwheel and typing in the desired value. The smallest increment for the value box is 0.1. The smallest increment for the thumbwheel is 0.5. The default azimuth is 65. Using the Azimuth thumbwheel while pressing the Ctrl key causes continuous, autonomous azimuthal rotation. Clicking the Azimuth thumbwheel again stops the continuous rotation.

Reset Inclination and Azimuth

Selecting the Reset Inclination and Azimuth icon button resets the inclination and the azimuth to the default values of 35 and 65, respectively.

X/Y Map View

Selecting the green X/Y Map View icon button manipulates the display into orthographic map view, oriented with North up. Mouse rotation is disabled. If the Shift key is held down while selecting the green X/Y Map View icon button, a new window pops up containing the map view.
X/Y, X/Z, and Y/Z Plan Views

Selecting the X/Y Plan View icon button manipulates the display so that the maximum X/Y plane is facing forward. Selecting the X/Z Plan View icon button manipulates the display so that the maximum X/Z plane is facing forward. Selecting the Y/Z Plan View icon button manipulates the display so that the maximum Y/Z plane is facing forward. Selecting the Reset Inclination and Azimuth icon button resets the inclination and the azimuth to the defaults. If the Shift key is held down while selecting a plan view icon button, a new window pops up containing the plan view. The zoom/pan can be reset by holding down the Ctrl button and clicking with the left mouse button.

Z Exaggeration

The controls shown to the left are available to change the vertical- or Z-exaggeration from the default value. The default value, which appears in the Z exaggeration text box, is automatically calculated by the Demo 3D Viewer to give a reasonable display, close to a cube. If the model contains mixed units (e.g., if the XY units are feet and the Z units meter), the Demo 3D Viewer adjusts the Z exaggeration accordingly. For example, if the XY range is 1 foot and the Z range is 1 meter, a Z-exaggeration of 1 would make the 1-meter side appear approximately three times longer than the 1-foot side.

A Z exaggeration value can be entered in the Z Exaggeration value box to either stretch or flatten the model. The up arrow icon button increases the Z-exaggeration by a factor of 1.25 (hot key, for “stretch”), while the down arrow icon button decreases the Z-exaggeration by a factor of 1.25 (hot key, for “de-stretch” or flatten). The actual ratio of the Z scaling to the X/Y scaling is shown in the Z Exaggeration value box.

Reset Z Exaggeration

Selecting the Reset Z Exaggeration icon button resets the Z exaggeration to the default setting.
Lock Z Exaggeration

Selecting the Lock icon button “locks” the Z exaggeration so that any changes to the Model window that would normally change the Z exaggeration would not affect it.

Zoom

The zoom function has the effect of changing the viewer’s position along the line of sight. Zooming in moves the eyepoint closer to the look point, resulting in the model becoming larger on the screen. Zooming out has the opposite effect. As the eyepoint is moved closer to the model, the axes’ labels are turned off as they can become significantly distorted. When the model becomes larger than the screen, it is truncated at the screen limits. The rotation functions, as well as all other functions, are always available even when zoomed in very close or zoomed out very far.

Pressing and holding the Zoom thumbwheel with the left mouse button, rolling it up zooms the model out, moving it farther away from the user. It has the same effect as typing the hot key \( O \). Moving the thumbwheel down zooms the model in. It has the same effect as typing the hot key \( I \).

Each time the Zoom In hot key \( I \) is typed, the eyepoint is moved 15% of the current distance closer to the look point, which, by default, is the model center (although this can be changed; refer to Set Look Point to 3D Cursor). Each inward move covers a smaller distance, although it is the same percentage amount. Thus, the eyepoint can approach, but not move onto the model’s look point or center. The Zoom Out hot key \( O \) moves approximately 18% of the distance away from the model’s look point each time.

Since property models are generally displayed in perspective (this can be turned off; refer to Perspective/Orthographic) parallel lines converge front to back. As the eyepoint moves closer to the model, the angle of convergence increases consistently with the rules of perspective. The visual effect is the same as moving a zoom lens from a wide-angle to a telephoto setting.

Rotation While Zoomed In

Two issues may occur when rotating while zoomed in on a location: the location of interest may disappear outside of the Model window or the rotation may appear to work in a backwards manner.

If the location you are interested in disappears outside the Model window, using the Centering Tool icon button can be very useful. This function, described earlier, sets the lookpoint and the rotation point to the selected spot. Once the lookpoint is moved to the location of interest, all zooming and rotation is centered around the desired location. Refer to Centering Tool for more details on this feature.
When viewing a model from a very close viewpoint, the rotation commands may seem as though they are working in a reversed manner. This occurs when most of the visible portion of the model is behind the look point because the direction indicated by the rotation command always applies to the part of the model in front of the look (pivot) point.

Zoom In on an Exact Location

Sometimes it is desirable to zoom in on a particular location. In addition, sometimes a portion of a model moves off the screen while zooming. Under both of these circumstances using the right mouse button to pan and the middle mouse to zoom allows the user to view the desired area. Alternatively, the Centering Tool icon button can be used to change the look point to the desired area. Refer to Centering Tool for more details on this feature.

Reset Zoom

Selecting the Reset Zoom icon button resets the Zoom thumbwheel control to its default setting.
Pan

Pressing and holding the horizontal or vertical Pan thumbwheel with the left mouse button, moving the thumbwheel moves the model in the same direction. For example, rolling the vertical thumbwheel up moves the model up, rolling it down moves the model down, rolling the horizontal thumbwheel left moves the model to the left, and moving it right moves the model to the right.

The look point can be changed such that any portion of the model is in the middle of the screen using the right mouse button and either the Ctrl or Shift key pressed.

**Note:** When in Select mode, the Ctrl or Shift keys may be held down for manipulation; when in Manipulate mode, the Ctrl or Shift keys need not be used.

The mouse pointer can be anywhere in the Demo 3D Viewer display screen. Moving the mouse pointer moves the model in the XY plane of the screen in the same direction as the mouse pointer (e.g., moving the mouse pointer towards the right and up, moves the model to the right and up). Changing the look point has the effect of panning along the model.

Keeping either key (Ctrl or Shift) pressed and changing which mouse button is pressed shifts from changing the look point to zooming to rotation and back to any of the others without having a redraw occur with each change. In addition, since the display is not redrawn until the Ctrl or Shift key is released, if the cursor gets too close to the edge of the screen to make panning comfortable, the mouse button can be released (without releasing the other key), the cursor repositioned on the mouse pad, the mouse button re-pressed, and the panning continued. These controls also make it very easy to view an exact location.

Reset Lookpoint

Selecting the Reset Lookpoint (i.e., home) icon button resets the Pan thumbwheels to their default settings.
Demo 3D Viewer Panel Window

The Demo 3D Viewer Panel window (also referred to as the 3DV Panel), which appears to the right of the Demo 3D Viewer Model window, contains five major components. Each of these is discussed below:

- File Selection pane
- Slice tab
- Visible tab
- Render tab
- Edit tab

File Selection Pane

Every file loaded into the Demo 3D Viewer is listed in the File Selection pane in the order in which they were loaded. The highlighted file name indicates the active file; by default, it is the first file loaded into the Demo 3D Viewer. The File Selection pane controls which files are visible and which file (or files) is "active"; changes made on any tabbed menu only apply to the active file(s).

To select a different file, simply click on the file name in the File Selection pane. To select more than one file, hold down the Shift or Ctrl key while clicking on the desired file names.

The tabbed windows below the File Selection pane display controls that only apply to the active (highlighted) files.

Each file can be displayed or hidden using the checkbox to the left of the file name. Hiding a file does not remove it from the Demo 3D Viewer; the file is still in memory, it is simply not displayed.

All files can be turned on or off using the Visible checkbox underneath the File Selection pane.

The default is to render the model scene repeatedly when dragging a slider handle. If rendering performance is slow, immediate rendering can be disabled by selecting the Immediate Render push button, to the right of the Visible checkbox.

Selecting the Paint Bucket icon button colors the selected file with a single, solid color. For example, a faces file might have horizons and fault blocks, each a unique color. Selecting the paint bucket icon colors the faces file a single color (to return the faces file display to numerous colors, use the Attribute Visibility settings on the Visible tab).
Selecting the Solid Color icon button produces a color palette window displaying the available basic colors; a custom color can also be created. A color can be selected for the solid color that is used when the Paint Bucket icon is selected.

Right Clicking in the File Selection Pane

Right clicking on any file in the File Selection pane produces a pop-up menu with the following options:

- **Unload File(s) from Viewer** removes the selected file(s) from the Demo 3D Viewer. If edits were made to a file that have not yet been saved, a prompt inquires whether to save the edits before unloading the file.

- **Reload File(s) to Viewer** reloads files into the Demo 3D Viewer; removes file(s) from visibility cycling groups, and deselects Make Z Units Unknown.

- **Duplicate File(s)** duplicates the selected file(s) in the same space. The original file and the duplicated file names have numbers appended (i.e., 1, 2, etc.) where 1 is the original file, 2 is the duplicate, 3 would be another duplicate, etc.

- **Vue Snippet** saves a "vue file snippet" for the selected file. The vue file snippet is saved and then automatically loaded whenever the selected file is loaded. This allows visibility and attribute settings for a particular file to be maintained, even without using a specific vue file. For example, a specific property data file can default to being colored by P.

Changing the File Selection Pane Size

The sash that separates the File Selection pane from the notebook tabs can be dragged up or down using the left mouse button. The mouse pointer changes to an up/down icon when the mouse pointer is in the correct position to make this adjustment. This shortens or lengthens the File Selection box and hence the number of files that are displayed in the list box. Also see Edit -> Preferences to set the Pane Layout.
The **Slice** tab is divided into the following sections, each of which is discussed below:

- **Boundary Slicing** ....... slices into the model or display.
- **Slice Animation** ........ used to animate the slicing into the model or display.
Boundary Slicing

The Boundary Slicing section of the Slice tab contains the following controls to slice into a model or display:

- **X-, Y-, and Z-axis Slicing** controlled using the slider bars and the *Reset Slider Settings* icon button to the right of each slider bar. The slider bars can be manipulated using the handle(s) on the bar, the arrows underneath the bar, or by entering a minimum and maximum value for the handle in the text boxes below the bar.

- **i-, j-, and k-Direction Slicing** controlled using the slider bars available when a 3D cellular grid is the active file. The sliders work the same way as the X, Y, and Z sliders do, but remove cells along the desired direction.

- **Reset All Slices** (or the **End** hot key) resets all slices, including the chair slices, back to the full extent of the model (chair mode stays on, but the chair slices return to their default position). When a model has been extensively cut, it is quicker to use the **Reset All Slices** function (located beneath the last of the three sliders) to restore each of the cut faces than to reset each slice control individually using the *Reset Slider Settings* button for each slider bar.

- **Slice Along Axes** setting the *Slice Along Axes* checkbox on enables direct slicing along any of the 3D axes by clicking and dragging the slice. The model axes turn yellow and purple drag controls are placed on the model axes. The purple slice controls can be pressed and dragged to change slicing immediately and interactively within the Model window. The *Slice Along Axes* does not operate on cell grids.

- **Slice to Cursor** slices the model to the 3D cursor location (hot key **Ctrl+K**). First, clicking the 3D Cursor icon button displays the 3D cursor. The 3D cursor is then moved to whatever location the user wants to slice. Then, selecting one of the *Slice to Cursor* icon buttons (i.e., Front X Slice to Cursor, Front Y Slice to Cursor, or Front Z Slice to Cursor) slices that front plane to the 3D cursor location. The *Slice to Cursor* function does not operate on cell grids.
• **Chair Mode** (or the Insert hot key) removes a subsection of the model at the corner nearest the viewer’s eye. The amount removed (one-eighth of the portion of the model shown) is determined by the current X, Y, and Z slicing positions (front and back)—the chair slices come up halfway between each of the current minimum and maximum slicing planes (see diagrams below). The Chair Mode function does not operate on cell grids.

![Chair Mode Off](image1) ![Chair Mode On](image2)

• **Chair Lock** By default, when the azimuth and/or inclination is changed while chair mode is on, the chair subsection that is removed remains the same, regardless of the angle; this is known as having the Chair Lock icon button on. Alternatively, the chair subsection can change such that the portion closest to the user’s eye is removed as the rotation angle is changed. In other words, the portion of the model that is the chair changes as the azimuth and/or inclination is changed, but it is always the section closest to the user. Freezing the chair subsection in place is activated by either selecting the Chair Lock icon button or the slash (/) hot key.

**Slider Handle and Value Manipulation**

When a single file is selected, slicing only occurs on the selected file. Multiple files can be selected by pressing the control button while selecting multiple files from the File Selection pane. A series of files can be selected by pressing the shift button while selecting the first and last files in the series; the first file, the last file, and all files in between are automatically selected.
The handle position can be moved directly to a location, by clicking the cursor at the new position desired for the handle. The handle closest to the cursor position then moves immediately to the place where the mouse button was clicked. If, after pressing down, the mouse button is not released, the handle is “tied” to the position of the cursor and can be dragged to any position. In this way, the cursor does not need to be placed directly on the handle in order to move the handle. With two or three handles, care should be taken to place the cursor closest to the handle to be moved.

Value Boxes and Arrows

Three other methods exist for changing a slider bar. The settings can be changed incrementally by clicking on the arrows below the box(es). Clicking on the right arrow moves the corresponding handle to the right; clicking on the left arrow moves it to the left. A value can also be entered directly for the setting by clicking with the left mouse button on the value box below the bar. (Clicking on the left box changes the value for and the position of the left handle; clicking on the right box changes the right handle; and similarly for the middle box and middle handle when using Chair Mode.) If the user enters a value that is not available, the Demo 3D Viewer rounds to the nearest available value.
Linked Scattered Data Point Slicing

Simultaneous (linked) slicing of scattered data files (i.e. .dat, .path, .pdat files) with other files (.faces) is available by linking these different files together. Files can be linked by selecting the scattered data file and choosing the file to link to using the pull-down list in the Linked Slicing section on the Slice tab, as shown below.
Once linked slicing has been enabled, both files must be selected in the File Selection tree to get linked slicing. Linked files can optionally be sliced using an offset distance entered in the boxes under the Linked Slicing section on the Slice tab. The offset distance is the distance between the slicing location of the two files. Different horizontal (XY) and vertical (Z) offset distances are allowed. The defaults for these offsets is zero (i.e., both files are sliced to the same location). Applying an offset can be extremely useful when QC’ing a faces file structural model against the relevant input scattered data file, for example.

Slice Animation

Animation involves cycling through the planar slices of a faces file or 3D grid (but not 3D cellular grids) one at a time along any single user-specified axis. Animation is also used to cycle through time in a data set that contains temporal (recurrrent) information. Only one planar direction can be animated at a time.

During the animation, the rotate, zoom, and pan hot keys are still functional. These hot keys include the arrow keys (for rotation), the I and O keys (for zoom in and zoom out), the Ctrl+arrow keys (for panning), and the Ctrl/Shift+ mouse button keys (for rotation, zooming, and panning).

The following controls are on the Slice Animation section:

- **Attribute** ............... This combo box controls which attribute is used for animation. The choices are None, X, Y, and Z (or I, J, K, and None in the case of recurrent cellular grids). The combo box selects which set of planar slices are cycled through for the animation. Once the axis is selected, a set of green arrows appear on the selected axis’s slider bar. The green arrows set the range of the animation while the slider bars regular handles set the width of the “slice” to be animated. The animation moves this small portion along the length of the selected axis defined by the green arrows. In order for the animation to be effective, the slider bars handles must be set to a smaller portion of the total range set by the green arrows.
- **Mode** ................. The Loop and Swing radio buttons control what happens when the animation reaches the end of the planar slice’s range. Loop repeats the animation in the same direction, starting back at the beginning (or end) after the last (first) slice is reached (depending on the Front to Back setting, discussed next). Swing reverses the direction when the animation reaches the end.

- **Initial** ................. The Front to Back checkbox specifies whether the animation moves the sliced portion towards the eye point (Front to Back is on (i.e., checked), the default) or away from the eye point (Front to Back is off).

- **Frame Time** ............ The Frame Time is used to specify the minimum amount of time (in seconds) each display remains on the screen. The default is 0.2 seconds. Setting the Frame Time to 0 allows the animation to run as quickly as possible.

- **Play** ................. Selecting the Play icon button (right-facing arrow) plays or starts the animation.

- **Stop** .................. Selecting the Stop icon button (black square) stops the animation.

- **Pause** ................. Selecting the Pause icon button (double vertical bars) pauses the animation, or restarts the animation when already in Pause mode.

- **Rewind** ............... Selecting the Rewind icon button (vertical bar with two left-facing arrows) rewinds the animation to the beginning frame.

- **Fast Forward** ........ Selecting the Fast Forward icon button (two arrows with a vertical bar) fast forwards the animation to the final frame.

**Planar Slicing**

The X, Y, and Z planar slices can each be turned off individually using the corresponding Visible checkboxes, or all at once using the All checkbox. The plane locations can be moved using the slider bars. As the Planar Slices slider bars are modified, the changes are immediately displayed in the Model window, allowing for rapid reconnaissance through seismic volumes.
Visible Tab

The Visible tab controls, on an attribute-by-attribute basis, what portions of the active model, grid, or data set are displayed and how they are colored. For example, a particular fault block or zone could be turned on or off, or those portions above a certain property value can be made invisible. Controls are also available to color data based on the values of any of its attributes.

It is important to understand the difference between the two attribute types as they are handled in different ways:

- **Discrete Attribute** is any numerically discrete or any non-numeric field, and is always represented with checkboxes that are used to control the feature's visibility.

- **Numeric Attribute** is any continuously varying property, and is always represented with a slider bar.

At the top of the Visible tab are two columns listing all of the available discrete and numeric attributes for the currently active file—these lists are used to filter which attributes are displayed in the remainder of the Visible tab. Below the two lists of attributes are columns of checkboxes—one column for each Discrete Attribute and one checkbox for each unique value of that attribute. At the bottom of the tab are horizontally arrayed sliders, one for each Numeric Attribute. If the selected file has no attributes, the controls on this tab remain blank. The icons and controls around these three sections (the lists and the two sets of attributes controls), are detailed below.
Discrete and Numeric Filter Lists

These two lists contain the names of all the Discrete and Numeric Attributes in the currently active file (as selected in the File Selection list). By default, all the attributes are highlighted, and hence all the attributes are represented in the Discrete and Numeric Attribute sections in the Visible tab. By deselecting or reselecting the different attribute names, those attributes are removed or added to the Discrete and Numeric Attributes lists. This is a useful process when there are dozens or hundreds of attributes in a single file (for example a typical reservoir simulation grid might have over one hundred numeric attributes), and hence by deselecting most attributes the user can quickly find the attribute of interest.

Attached to the attribute lists are several icon buttons that control the appearance of the attribute lists, as described below:

Selecting the Funnel icon button selects (or deselects) all the attributes on the list of Discrete or Numeric Filters.

Selecting the Temporal Attributes icon button filters either the discrete attribute checkbox list or the numeric attribute slider list such that only attributes with a temporal component are shown in the attribute lists.

Selecting the Reset All Discrete icon button resets all the Discrete Filters making all attribute values visible. In other words, if the visibilities of any of the values in any of the attributes have been turned off, then selecting this icon will make all values of all discrete attributes visible again.

Selecting the Reset All Numeric Filters icon button resets all the Numeric Filters making all attribute values visible. In other words, if the visibilities of any of the values in any of the attributes have been filtered off, then selecting this icon will make all values of all numeric attributes visible again.

Discrete Attributes

Each Discrete attribute is represented by a vertical column of checkboxes, with one checkbox for each unique value of that attribute. Setting the toggle buttons/checkboxes to off turns off the visibility of all elements of that attribute value (for example, turns off all wells with wellid of the deselected value). The tools below each discrete attribute column apply to that attribute alone, and are described here:
The Discrete Attribute Text Filter box provides an easy way to shorten the list of Discrete Attribute checkboxes. The list of values for the given attribute are filtered based on the string typed into the text filter box. For example, if the letter ‘A’ is entered into the box, then only the attribute values containing the letter ‘A’ are displayed in the Discrete Attribute checkbox list. The X icon button next to the text filter box resets the filter and makes all attribute values visible again. Note, that there are sometimes many thousands of unique values within any discrete attribute, and hence the list of checkboxes can become extremely long, and take a very long time to render onscreen. A limit on the total number of checkboxes visible at any one time is provided in the Viewer Preferences settings.

Selecting the Reset All Discrete icon button resets the visibility of all the values for the given attribute, making all values of that attribute visible.

Selecting the Reverse button reverses the current visibility settings of the given attribute; any values set to on are turned off and vice versa.

Selecting the Color button colors the entire data set based on the values of the selected attribute.

Further color controls are accessed by using the file palette drop-down menu. The file palette drop-down menu, shown to the left, contains the following functions:

- **Load Default Colors** loads the default colors. Depending on the file this could be the DGI default zone color table, faultblock color table or feature color table. Other color tables can be specified by selecting the next function, Load Custom Colors, discussed next.

- **Load Color File** loads a user-specified color file from the file directory. A set of color files are also supplied with the Demo 3D Viewer software. Depending on the type of discrete attribute, the following discrete color tables may be available:
  
  - zone colors
  - faultblock colors
  - label colors
  - feature colors
Numeric Attributes

At the bottom of the Visible tab are a series of horizontal sliders—one for each selected numeric attribute in the currently selected file. When a data set is being colored by one of its numeric attributes, the associated property slider is also colored. To change the attribute that is colored, select the desired attribute then select the Apply Colors From This Attribute (paint bucket) icon button. The small colored handles on the slider bar then become active. These handles are used to either define and limit the range over which the attribute is visible, or to remap the colors for the attribute, or both. These functions are described further below, together with additional icon control buttons that relate to that specific numeric attribute.

Selecting the Reset button resets the handles to the extents of the numeric attribute slider bar such that all values for the given numeric attribute are visible.

Selecting the Reverse button reverses the current setting of the visibility attribute. When used on the numeric attribute sliders, if the inner range of the slider is being displayed, then selecting the Reverse icon causes the outer range to become displayed (i.e., those values outside the slider handles become visible).

Selecting the Color button colors the entire data set based on the values of the selected attribute. The slider bar will take on the colors of the attribute when this function is selected.

Selecting the Color Palette icon button produces the menu shown to the left for numeric attributes. It contains the following functions:

- Load Default Colors ................. loads the default colors. For most numeric properties this is a “spectrum” color scheme ranging from red to purple. For Seismic properties the default is a red/white/blue color table. Other color tables can be specified by selecting the next function, Load Color File, discussed next.

- Load Color File ..................... loads a user-specified color file from the file directory. A set of color files are also supplied with the Demo 3D Viewer software.

- Reverse Colors ................. reverses the order of the colors.
Selecting the Remap Colors to Slider Handles button redistributes the entire color range to the extents of the slider handles. When this mode is enabled, the slider handles are colored red. In this way colors can be compressed across a smaller range of numeric values, thus bringing out subtle details in the data that might otherwise be indistinct. This mode can be used in an interactive fashion, with the colors getting continuously updated as the user moves the positions of the slider handles. Note that this mode can be used in conjunction with the Visibility mode, as discussed below (when the modes are used together, the slider handles are colored yellow).

**Note:** In general, only one attribute can ever be used at one time to color a single file. And hence only one numeric slider at a time will be colored. There are two exceptions to this rule: firstly, when using Ternary coloring three sliders will be colored (one green, one red, one blue); secondly, when using a cell grid with Local Grid Refinements (LGRs). If the LGR's have a different array of attributes relative to the root grid, then multiple attributes (some from the LGRs, one from the Root grid, perhaps) may used for coloring simultaneously.

Selecting the Visibility button allows control over the range of numeric attributes that are visible on the screen. When this mode is selected the slider handles are colored blue. The attributes visible on the screen are those in the range between the two blue slider handles (unless the reverse mode is toggled on, whereupon the values outside the two blue handles are visible). This mode can be used in an interactive fashion, with the visibility getting continuously updated as the user moves the positions of the slider handles. Note that this mode can be used in conjunction with the Remap Colors to Slider Handles mode, as discussed above (when the modes are used together, the slider handles are colored yellow). In this combined mode, the color and the visibility of the attribute gets continuously updated as the yellow slider handles are moved. Note that either the Remap Colors to Slider Handles or the Visibility mode, or both, are always selected (as denoted by the “pushed-in” icons below the numeric attribute slider).

### Linking Property Data Files and Property Faces Files in the Viewer

Data files such as property scattered data, 3D grids, and cellular grids, can be linked together with the property colortables in a property faces file. In this manner, the on-screen colors will match between the faces file and the secondary file—ensuring a consistent appearance for QC purposes, for example.

When data files are loaded into the Viewer their properties are displayed in a continuous coloring fashion (each color effectively represents a single unique value) whereas faces files always have discrete property coloring (one solid color per isoshell where a isoshell represents a range of property values, not a single value). Hence to color-link to a faces file the property data file must adopt discrete coloring.
To link the files, select the faces file in the File Selection list. On the Visible tab, select the appropriate color palette icon for the property to link and choose Link attribute colortables discretely (see image below).

If more than one faces file is loaded into the viewer, the option to choose which faces file to link to is available when the property data file is selected. Additionally, non-faces attribute files can link to all
other non-faces files with continuous property coloring or can be linked to all files plus a faces file using discrete rendering. Note that all attribute linking in the Demo 3D Viewer requires that the data files and the faces files all have the same attribute property name (i.e., “Porosity”).

Render Tab

The controls on the Render tab are specific to the file type for the file selected in the File Selection pane. The controls specify Z contouring parameters, file transparency, symbol display, line display, label posting, draped image/file display, map pins (discussed in Appendix C: Symbols, Line Types, Colors, Fonts, and Patterns), well tube display and various other display attributes of other file types. Each of these controls is discussed in the following sections.

Volume Outlines

When a faces file (.faces) is the selected file type, zone outlines, property isoshell outlines, and faultblock outlines can be toggled on and off. Additionally, line color and thickness can be changed, or only the zone outlines of the faces file can be rendered.
Z Contouring

When a faces file or scattered data file is the selected file type, a Z Contouring section appears in the Render tab. The Z-Contouring option colors the top surfaces of the file with a color corresponding to the elevation (or depth) value of that point in space. The Z contouring is done on a by file basis, as controlled by the respective icon buttons.

The slider bar displays the range over which the Z contouring is applied. The text boxes and arrows beneath the slider bar can be used to change the minimum and maximum Z values within which contouring is applied. Selecting the Color Bucket icon beneath the slider bar turns Z color-filled contouring on. The Color File icon button is used to change color files. The Home icon button resets any changes made back to the defaults.

The controls beneath the slider bar control the contouring interval (the Interval text box), the color number at which the colored contours will start (the Start text box), and the number of colors to be skipped between consecutive colors (the Step text box).

The colors used for Z contouring can be modified using the Color Palette icon button, which produces a pull-down menu containing the following options:

- **Load Default Colors** loads the default colors. For most properties this is a "spectrum" color scheme ranging from red to purple. Other color tables can be specified by selecting the next function, Load Custom Colors, discussed next.

- **Load Color File** loads a user-specified color file from the file directory. A set of color files are also supplied with the Demo 3D Viewer software.
Fault Face Color

When a 3D model (faces file) is displayed, a Fault Face Color section appears on the Render tab. By default, fault faces are displayed in a neutral color. Checking the Neutral Color Faults checkbox off causes the fault faces to be colored in the same coloring used by the rest of the faces file (e.g., zone or property colors).

File Transparency

Checking the Transparency checkbox makes the file currently highlighted in the File Selection pane transparent so that items such as a wellpath hidden by the file can be seen. Selecting the Transparency checkbox again, so that the check mark disappears, removes transparency, making the selected file opaque. If a faces file is displayed together with multiple wells, the faces file may, for example, hide some of the wells. Turning transparency on would allow both the faces file and the wells to be seen.

Wireframe Rendering

Checking the Wireframe Rendering checkbox makes the currently active file render in wireframe mode. In this mode only the edges along certain polygons are visible, thus allowing the user to see “inside” or “through” the object in question. This can be extremely useful when multiple objects are displayed on the screen simultaneously. For example, the user could wireframe render a reservoir simulation grid to see the streamline data “inside” it.
Symbol Display

When a scattered data, property data, or wellpath file is selected, the Symbol Display section appears on the Render tab. This section contains three functions:

- **Scale**
  
  The size of the symbols displayed at each point location can be scaled up or down using the **Scale** text box. By default, the scale is set to 1. Setting the value to 2 would make the symbols twice as large; a value of 0.5 would make them half as big. The arrow buttons can be used to increase or decrease the scale factor.

- **Point (Pt) Render**
  
  By default, all data locations are displayed either in their symbol shape as defined in the file or as a default cube, unless the number of points displayed is equal to or greater than the value set for the **Point Rendering Count** on the Render tab in the Preferences window (accessed via Edit -> Preferences). All data locations may instead be displayed as a 2 pixel by 2 pixel point by turning **Point Render** mode on via the icon button. The Scale Factor still applies to the point render mode, thus the point can be made larger or smaller.

- **Strike/Dip**
  
  When dipping disks are displayed in a data file, the disks can be changed to ellipses with strike/dip symbols displayed by turning the **Strike/Dip** button on.
Annotation File Display

When an annotation file is the currently active file, the following additional options appear in the Render tab.

Annotation Line Width Scale

All the lines and polygons within an annotation file have a line width attribute. The Annotation line width scaling tool allows a global scale factor to be applied to the annotation file to make all the lines thicker or thinner to suit the scale of the visualization.

File-specified Colors

If this option is enabled, then the annotation file is rendered with its native colors—the ones that are specified within the file itself. There may be occasions when it is desirable to change these colors and render the file in a single, different color. To do this, disable this option and choose the color using the color palette selector at the base of the File Selection list.

Annotation Z plane

Annotation files contain no vertical coordinate information—they are purely a 2-dimensional data type. Even so, a vertical position must be provided to render the file within 3D space. This slider bar and the associated interface tools allow the user to specify the vertical coordinate location at which to display the annotation file.
Data Line Display

When a scattered data, property data, or wellpath file containing a line or well ID is selected, the Line Display and Label Posting sections appear on the Render tab. These sections contain the following functions:

### Line Display

- **Lines**
  - Data points with the same line or well ID are typically connected by lines. These lines may be turned on or off using the Lines checkbox.

- **Pixel (Px)**
  - The pixel width of the line connecting data points with the same line or well ID can be changed. The default width is 1 pixel. The width can be changed to be up to 5 pixels wide.

- **Point Color Segments**
  - Use the solid fill or line color (if field exists) for entire line, or use corresponding data point color for each line segment.

### Label Posting

- **Labels**
  - Any attribute, such as line ID or well ID, in a scattered data or path file can be posted at the top of each line by setting the Labels checkbox on. By default, the labels are placed at the top of the line. Selecting the Reverse icon (the curved arrows) sets the labels to the bottom of the wellpaths.

- **Size (Sz)**
  - The point size of the labels can be changed. By default, the Size combo box is set to a 12 point font. The size can be changed to a 8, 10, 12, 14, 16, 18, 20, 24, or 32 point font (not all font sizes are available on both Linux and Windows systems).
- **Reverse Position of Labels**. By default, when labels are turned on for display, they are placed at the top of each line. Selecting the Reverse icon (the curved arrows) sets the labels to the bottom of the wellpaths.

- **Field to Label**. The fields in the file are listed. The selected field is labeled.

- **Horizontal Offset**. The horizontal offset between the center of the symbol and the label. The offset is specified in “number of characters” and is proportional to the font size.

- **Z Offset**. The vertical offset between the center of the symbol and the label. The offset is specified in Z units. A positive value offsets the label above the symbol; a negative value offsets the label below the symbol.

**Tube Display**
When a scattered data, property data, or wellpath file containing a line or well ID is selected, the Tube Display section appears on the Render tab. The “tube” surrounds the line or wellpath, and may be set to have a single radius, radii that vary based on a radius field in the file, or radii that vary based on a different field in the file. This section contains the following functions:

- **Create and Modify Tubes**
  The first icon brings up the Create Tubes dialogue window. Using this window, shown above, tubes can be displayed on one or more lines or wellpaths, using either the Common ID or Well ID as the Tube Field. Each path can be given a set radius, and paths can be given different values. Alternatively, a field in the file can be used to set the radius along the length of the tube. For example, the radius can be set to be proportional to a property in the field, such as porosity. In addition, the radii can be scaled either by a single factor, linearly within a range, or logarithmically within a range. Once created the tubes can be turned on or off individually via the Tube dialogue. They can also be turned off all together, the ends can be capped, and radius of the tube can be affected by the Z exaggeration or not using the other icons in the Tube Display section (discussed next).

- **All icon**
  The All icon turns on all tubes that have been created when the button is set on; it turns off the display of all tubes when the button is off. Setting the display off does not “destroy” the tubes; it merely hides them.

- **Cap icon**
  By default, when tubes are created the ends are not covered; you can see the wellpath within the tubes. Setting the Cap icon on puts a cap or cover at the ends of every tube displayed.

- **Circular/Elliptical Tubes**
  By default, the shape of the tube takes into account such things as the Z exaggeration and the XY versus Z units of the display. In this way, the shape of the tube always reflects the actual numbers specified for the radii. Turning the Circular/Elliptical Tubes icon off always displays the tubes as a circle (i.e., a circular cross section) regardless of the Z exaggeration or differences in the units. When this setting is on, Z exaggeration will stretch the tubes vertically; it is important to note that the shape of the tube does not reflect the actual radii numbers in all cases. This setting should not be used if the tube is meant to show some sort of measurement.

- **Tube Facets**
  By default, tubes are drawn with 16 facets; allowable values are 4, 8, 16, 20, 24, 28, and 32. Larger numbers produce a more circular-looking tube, while smaller numbers produce less
circular tubes. There are speed and memory advantages to using smaller numbers. This is a global setting for all tubes, and gets saved to any vue files (.vue) that are created.

**Binary Well Displays (BWDs)**

An alternative way to display well logs is using a binary well display (.bwd) file. A binary well display file contains not only the well log values but the instructions to display the log to either the left or right of the well, together with color and scale information. Also, when a BWD file is the active file in the Viewer, the Render tab will contain controls for adjusting the overall width of the BWD track in the Viewer. In the
following illustration, the green log appears to the left of the well and the red log appears to the right of the well. As the display is rotated, the logs remain in their proper locations relative to the well.
Decimation Factor

The Line Decimation Factor reduces the number of lines or wells rendered by only drawing one of every N lines.

The Line Decimation Factor acts to reduce the number of visible line rendered objects by rendering only every nth object (where n is the number given in the interface). The setting acts on any file which uses the wellid, commonid, or lineid attribute. When the Line Decimation is set to 1, then every line-based object in the file is rendered. As the number is increased, then only select line-based objects are rendered. For example, imagine the case of a file with four wellids A, B, C, and D. With the Line Decimation set to 1, all four wells are rendered. If the Line Decimation is set to 2, then only every 2nd well is rendered, starting with the first (namely wells A and C would be rendered). If the Line Decimation setting is 3 then wells A and D are rendered, and with a setting of 4, only well A is rendered. This visibility filtering can act to significantly speed up rendering, and reduce visual clutter in the cases of large files.

Related to this, note that scattered data file headers can now accept a line reading:
# Line_decimate_factor: . If this line is present in the file header then the number following the parameters is used as the default line decimation factor when this file is loaded to the Demo 3D Viewer.
Spider Diagram Display

When a line-oriented data file is selected in the File Selection pane, the Render tab contains a Spider Diagram section, shown below, that controls the display of spider diagrams. This function flattens all wells to a single plane, and turns off the data symbols. This feature is particularly useful with path files whose wells all generally start close to one another, and then diverge with increasing Z. When this feature is enabled, all wells resemble spiders, as shown below.

Image Display

An image such as an aerial or satellite image can be displayed either on a plane or draped atop a structural surface. In order to drape an image on a structure, an image registration file (.imreg) must already exist (refer to Image Registration for more information). In the case of draping seismic attributes created from a SeisWorks database, the imreg file is created automatically; hence, in this case, the structure of the imreg file is of no concern to the user. When an image file or an image registration file is selected in the File Selection pane, the Render tab contains the following controls for draping the selected image:

- File Transparency . . . . . . The image can be displayed either transparently or as a solid surface, as controlled by the Transparency checkbox, so that items such as a wellpath hidden by the file can be seen.
- Image Z Plane . . . . . . . . The image can be displayed horizontally at a particular Z elevation. Use the slider bar, text box, and arrow buttons to position the Z plane, and select the Visible checkbox (so that a checkmark appears) to display the image.
• Image Draping . . . . . . . . . The image can be draped on one or more surfaces (2D grids or faces files). Use the tree to specify the surface on which the image is draped, by selecting the checkbox for the surface (so that a check-mark appears). Selecting the Drape All checkbox displays the image on all the available surfaces. If multiple images and multiple grids are loaded, you can specify which image is displayed on which grid. If the underlying surface extends beyond the image boundaries, selecting the Transparent Exterior checkbox allows the surface colors to be seen. If the underlying surface extends beyond the image and Transparent Exterior is not checked, the underlying surface is displayed in gray rather than in surface colors.
The Edit tab is used to edit and create items in files, for example, to edit data fields in a scattered data file. The controls on the Edit tab vary depending on the file type selected in the File Selection pane. The following illustration shows the Edit tab as it exists for a wellpaths file.
Graphic Data Editor

Graphic data editing is used to edit and display scattered data, property data, and well path data. The following features are available on the Edit tab on the Panel.
Data Files

In general, scattered data, property data, or well path files containing an x, y, and z-field can be displayed and edited in the Demo 3D Viewer. The file can optionally contain P-fields, as well as numerous other fields.

Active Edit File

Select and edit operations can be applied only to the currently active file, as shown in the Active Edit File box on the Edit tab. If more than one data file is open in the viewer, the “active” file defaults to the file highlighted in the File Selection pane on the Panel. Multiple files cannot be selected simultaneously for editing.

To Select a File for Editing

Do one of the following:

- Highlight the file in the File Selection tree.
- Select one of its data points using the pointer tool in the viewer.
- Click right mouse button on a data point and choose Select “filename” in Panel option.
- Use the Cycle button on the File Query window to choose between selecting data points in multiple files (see File Query section for more information).

Lock the Edit File

Selecting the Lock icon button locks the currently active file, as shown in the Active Edit File box, so that the Active Edit File cannot be switched, regardless of what is selected in the Model window. So if two scattered data files are open, and the first file is locked as the Active Edit File, the first file remains as the active edit file even if a point within the second file is selected, thus allowing the locations in the second file to be used to guide the point additions in the first file. Selecting the Lock icon button again unlocks the file.
Undo/Redo and Edit History

These commands are used to Undo or Redo recent edits. When a series of edits have been made, Undo reverses the most recent edit first. If Undo is selected again, the next most recent edit is reversed, and so on. The Redo command can be used to repeat/remake the last edit that was reversed by Undo.

The Edit History pull-down menu contains a list of recent edits. The edits are listed in order numerically with the highest numbered edit being the most recent one. Several edits can be undone or redone in a single operation using Edit History. By selecting an edit in the list and choosing Undo, all the previous edits from the top of the list down to the selected edit, but not including it, are undone. If new edits are made in the Viewer after using Undo, these removed edits are lost and cannot be restored using Redo.

Select Modes

In Select Mode individual or multiple data points can be selected. When point(s) are selected the File Query window contains the name of the file and the values of the data point selected. (See the File Query section for more information).

Note: For data with line-id or well-id, this information is displayed in the appropriate box on the Edit tab.

To Select a Point Using the Pointer Tool

- Left-click on a point.

To Select Multiple Data Points

Do one of the following:

- Check the Multiple Select box on the Edit tab and left click on a point.

- Use Lasso to draw around data points by holding down the left mouse button. Lasso mode is accessed via the Lasso button on the Edit tab or by right-clicking on a data point and choosing Select -> Lasso mode. The Lasso Plus icon button adds additional lasso selections to the current set of selected points; this mode is also selected by holding the + key while in Lasso mode. The Lasso Minus icon button subtracts additional lasso selections from the current set of selected points; this mode is also selected by holding the - key while in Lasso mode.
To Select a Line of Data Points

Do one of the following:

- Right-click and choose Select –> Select Entire Line.
- Use the Lasso function (see description in previous section).
- Double click on the line using left mouse button.
- Use Multiple Select and left-click on all data points in the line.

To Select All Data Points

- Right-click on a point in the viewer window and choose Select –> Select All Visible Points.

Selected points are colored light blue. If multiple points are selected the last selection is white and the previously selected points are light blue. If the viewer background is white selected points are colored light grey and turn light blue as multiple points are selected.

To Unselect a Point

- Left click on the selected point(s).

To Unselect All Points

Do One of the following:

- Use Clear button on the Edit menu or on File Query menu.
- Right-click and choose Select –> Clear Selections.

Select Operations

Two features are available under Select Operations; Clear and Invert. Clear will unselect all currently selected points and lines in the viewer. Invert reverses the current selections; all currently unselected points are selected and vice versa.
These two commands can also be accessed by right-clicking on a point and choosing Select → Invert Selections and Select → Clear Selections.

Edit Operations

These operations are used for creating and modifying data files, individual data points and lines of data points. Add adds points to the data file. Insert inserts a point between two data points connected by a line; a line ID or well ID is required to use this feature. For the Add and Insert commands points are added at the 3D cursor location (see details elsewhere for 3D cursor documentation).

Note: Edits apply to the Active Edit File only. Most importantly, edits are not saved to the data file automatically. The user can force a save of the edited file using File → Save. Alternatively, the user is prompted to save an edited, yet unsaved, file, when removing the file from the viewer or exiting the Demo 3D Viewer.

Add

- To add an individual data point, position the 3D cursor at the desired location and click Add or Ctrl+F (use keyboard shortcut, Ctrl+K, or select cursor icon in upper left of the Model window to turn on the 3D cursor)
- To add a point to one end of a line, select the endpoint, position the 3D cursor to location and Add or Ctrl+F.
- To add points to a well path file a valid well-id must be entered into the well-id box on the Edit tab before the Add option is available.

Insert

Insert adds a point on a line between 2 points using the following steps:

- Using Multiple Select mode pick 2 adjacent points on a line.
- Position the 3D cursor to the location to insert a point to the line.
- Click the Insert button or Ctrl+F.
- A line is drawn to the newly added point from each adjacent point.

When adding or inserting points, only the X, Y, Z, P, and well-id/line-id fields are added to the file. If the file contains other fields their value is null unless defaults have been set using the Edit Field Defaults command. See the Editing Field Defaults section for more information.
Delete

- To delete a point, select point and Delete or Ctrl+D.
- Right-click on a point and choose Edit Operations —> Delete Selected Point(s).
- To delete multiple points, select points and use Delete or hot key or Edit Operations —> Delete Selected Point(s).
- To delete a line, right-click on a point on the line and choose Select —> Select Entire Line and then right-click and choose Edit Operations —> Delete Selected Point(s) or double click on the line and then use any of the options listed above.

Move

- To move an individual point(s), select point in the viewer (left-click), position the 3D cursor to new location for point and click Move or right-click and choose Edit Operations —> Move Selected Point(s) or Ctrl+M.
- To move an entire line of data points, select line (double click, right-click and choose Select —> Select Entire Line, use Lasso), position 3D cursor and use Move, Ctrl+M or Edit Operations —> Move Selected Point(s).

Note:  If multiple points are selected only the last selected point is moved to the 3D cursor location. All other selected points are moved the same distance from their starting points in relation to the last selected point.

Digitize Mode

This command allows quick data point addition and line building along a surface or feature (2D grid, faces file, etc).

- Check Digitize mode and left-click in viewer to add data points.
- For line data, a well-id or line-id is required; otherwise individual points will result.
File Query

The File Query attribute window is displayed when data (e.g., scattered data, faces file, 2D grid, 3D grid, and cellular grid) is selected with the left mouse button, producing a File Query list box, shown above, displaying data for the selected point, surface dip and dip azimuth for 2D grids or faces files, and options to edit the file’s default values. The filename text box contains the name of the Active Edit File. As data points are selected in the viewer, File Query updates to the current selection (or last selected point). If the highlighted point is not exactly the desired point, selecting the Cycle icon button selects the next closest data, also referred to as cycling through the data. For example, imagine a vertical well in plan view so that all the points on the well are stacked up one behind the other, and the user clicks on the front-most point but actually wants one behind it. The first time the left mouse button is clicked, the Demo 3D Viewer selects the object closest to the eyepoint; this is when the Cycle button becomes active. Selecting the Cycle icon button deselects the currently-selected point and automatically selects the next point in the list, eventually cycling around to the first selected point. To the right of the Cycle label is the number of items through which the File Query is cycling.
Multiple windows can be opened by using the Pushpin (located to the right of the filename text box) to lock the current attribute window. Additionally, attribute data can be copied into a clipboard or text editor program by using the icon to the left of the filename text box.

Each File Query window includes three informational tabs as described below.

**Query**

- *Edit Table* allows editing of the selected point’s data values (although edits are not saved until File —> Save is invoked).

- The Cycle function is active when more than one file is displayed in the viewer and 3D objects overlap. Use this function to cycle through the selected items. The filename will change in the text box as Cycle is used. To the right of the Cycle label is the number of items through which the File Query is cycling.

- Clear will remove all attribute values on the Query tab and the selected point(s) in the viewer.

**Info**

![File Query Window](image)
As shown in the illustration, the *Info* tab on the File Query window displays the file path, version, description, XY and Z units, projection, ellipsoid, elevation above MSL (mean sea level), MD vertical offset, number of data points, number of wellpaths, number of fields in the file, and whether the data is temporal. This information is not editable.

**Edit Defaults**

This is the third tab in the File Query window and can also be accessed by selecting the *Edit Field Defaults* button on the Edit tab in the 3DV Panel.

The default field values for a file can be set so that these values are assigned when new data points are added. Under *Edit defaults*, the current file’s data fields are listed with their corresponding values (except for x, y, and z fields). Default values can be edited or entered here or left blank.

Grab Selected Point Values is used to apply the selected data point’s values as the defaults for a file.

Clear removes the current default values.

*Note:* *Data files containing only x, y, and z data fields will not have any default values to edit. Also note that the units of the fields cannot be changed in this window.*
**Text File Editor**

The **Text File Editor** button opens up the active edit data file in tabular format for editing. Features include adding fields, adding lines, renaming fields, changing units, hiding fields, as well as, undo and redo commands. Once edits are complete the file can be saved and the viewer updated to reflect changes.

While the **Text File Editor** is open all other functions on the Edit tab are disabled. If edits are made before opening the **Editor**, a pop-up message appears asking if those edits should be saved.

Icons at the top from left to right are:
Open File to Edit

Selecting the Open File to Edit button produces a Files window in which a file can be selected and opened for editing. Also, the current directory can be changed and a new directory can be created in the Files window. Selecting File -> Open has the same effect as selecting the Open File to Edit button.

Save File

Selecting the Save File button saves the edits to the file. Select File -> Save As to save the edits to a file name different from that of the input file. Selecting File -> Save has the same effect as selecting the Save File button.

Save File and Update Viewer

Selecting the Update Viewer button updates the data display in the Model window with the edits made in this editor. Selecting File -> Update Viewer produces the same function.

Add Line after Selected Line

Selecting the Add Line after Selected Line button puts a new blank line into the file after the currently selected line. Data can then be entered in the new cells.

Insert Line before Selected Line

Selecting the Insert Line before Selected Line button puts a new blank line into the file before the currently selected line. Data can then be entered in the new cells.
Delete Selected Line(s)

Selecting the *Delete Selected Line* button deletes the selected line from the file.

Add Field to File

Selecting the *Add Field to File* button adds a new field to the file, at the end of the record. The new field is named *field#* where # is the number of the field in the file (e.g., if the file originally has 3 fields and two new fields are added, the new fields are named *field4* and *field5*).

Delete Selected Field(s)

Selecting the *Delete Selected Field(s)* button removes the currently selected field from the data file.

Hide Selected Field(s)

Selecting the *Hide Selected Field(s)* button hides the currently selected field(s) from the Data Fields Editor window. The field is not removed from the file; it remains in the file but simply is not displayed. This function is helpful when the file being edited has a large number of fields and the last field in the file must be edited. Hiding fields makes the Data Fields Editor window narrower, so that the last field is easily viewed without needing to use the scroll bar to move to the right.
Make All Fields Visible

Selecting the Make All Fields Visible button displays all fields, even those previously hidden, in the Data Fields Editor window.

**Note:** Undo and Redo only work on the last change. No edit history is contained in the Text File Editor.

A single cell can be copied and pasted into multiple cells by highlighting the cells to paste to while holding down the left mouse button. In addition, multiple cells and columns can be copied and pasted in the same manner as long as units match for the fields.

By double-clicking on a column header, a drop-down list of default field names appears and allows a user to choose a default or type in a field name. The Units header will also display the available default names by double-clicking on it.

Row height and column width can be manipulated by holding the cursor on a row or column line until the double-arrow icon appears; moving the cursor will modify the row or column.

File Pull-Down Menu

The File pull-down menu contains the following:

- **Open (Ctrl + O)** . . . . . . Opens a file for editing.
- **Save (Ctrl + S)** . . . . . . Saves the edits to the file currently being edited.
- **Save As** . . . . . . . . . . Saves the edits to a user-specified file name.
- **Update Viewer** . . . . . . Updates the data display in the Model window with the edits made in this editor. Selecting the Update Viewer icon button produces the same function.
- **Exit (Ctrl + Q)** . . . . . Exits the Data Fields Editor. If the edits have not yet been saved, an inquiry is issued asking whether to save the edits before exiting the editor.
## Edit Pull-Down Menu

The Edit pull-down menu contains the following:

<table>
<thead>
<tr>
<th>Keyboard Shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut (Ctrl + x)</td>
<td>Cuts or removes the selected (i.e., highlighted) item(s) from the file. The selected item could be a single item, an entire row or column of items, or a group of rows and columns of items.</td>
</tr>
<tr>
<td>Copy (Ctrl + c)</td>
<td>Copies the selected item(s) from the file.</td>
</tr>
<tr>
<td>Paste (Ctrl + v)</td>
<td>Pastes the previously cut or copied item(s) into the file at the selected point.</td>
</tr>
<tr>
<td>Undo (Ctrl + z)</td>
<td>Un-does previous edit(s), one at a time.</td>
</tr>
<tr>
<td>Redo (Ctrl + y)</td>
<td>Re-executes previous edits, one at a time.</td>
</tr>
<tr>
<td>Copy Line</td>
<td>Copies a line or record.</td>
</tr>
<tr>
<td>Add Line</td>
<td>Adds a new blank line after the currently selected line.</td>
</tr>
<tr>
<td>Insert Line</td>
<td>Inserts a new blank line before the currently selected line.</td>
</tr>
<tr>
<td>Delete Line</td>
<td>Deletes the currently-selected line from the file.</td>
</tr>
<tr>
<td>Copy Field (Ctrl + c)</td>
<td>Copies the data value in the currently selected field and record (known as a cell) to the clipboard so that it can then be pasted.</td>
</tr>
<tr>
<td>Add Field</td>
<td>Adds a new field to the file.</td>
</tr>
<tr>
<td>Delete Field</td>
<td>Deletes the currently-selected field from the file.</td>
</tr>
<tr>
<td>Rename Field</td>
<td>Renames the currently-selected field.</td>
</tr>
<tr>
<td>Hide Field</td>
<td>Hides the currently-selected field(s) in the file.</td>
</tr>
<tr>
<td>Show All Fields</td>
<td>Shows all the fields in the file, even those previously hidden.</td>
</tr>
</tbody>
</table>

## Image Registration

The Image Registration functionality is used to register an image file to data (real-world) coordinates. To initiate the image registration process, follow these steps:

- Load a 3D model into the Viewer
- Load an existing image registration file

An existing image registration file can not be modified in the Demo 3D Viewer, due to limitations of the Demo program.
Appendix A: Screen Annotation Fonts

Screen annotation displays text, lines, rectangles, and circles on a Demo 3D Viewer screen. These annotation objects are positioned relative to the X,Y locations of the graphic display window, unlike surface annotation, which are displayed relative to the X,Y locations of the ASCII data or faces file.

This appendix shows samples of the available fonts: Arial, Courier New, Helvetica, Century Schoolbook, and Times New Roman. Sample point sizes are also included (supported point sizes are from 8 to 32).

Sample Fonts

Arial

<table>
<thead>
<tr>
<th>Font</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arial</td>
<td></td>
</tr>
<tr>
<td>Arial Bold</td>
<td></td>
</tr>
<tr>
<td>Arial Oblique</td>
<td></td>
</tr>
<tr>
<td>Arial Bold Oblique</td>
<td></td>
</tr>
</tbody>
</table>
### Sample Point Sizes

<table>
<thead>
<tr>
<th>Letter Size</th>
<th>Point Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABCD</td>
<td>8 point</td>
</tr>
<tr>
<td>ABCD</td>
<td>10 point</td>
</tr>
<tr>
<td>ABCD</td>
<td>12 point</td>
</tr>
<tr>
<td>ABCD</td>
<td>14 point</td>
</tr>
<tr>
<td>ABCD</td>
<td>18 point</td>
</tr>
<tr>
<td>ABCD</td>
<td>24 point</td>
</tr>
<tr>
<td>ABCD</td>
<td>32 point</td>
</tr>
</tbody>
</table>
Appendix B: Hot Keys

“Hot keys” are one-key or two-key strokes available in order to quickly perform a command. They allow users to perform commands without moving to the appropriate menu, to move from menu to menu without selecting the Main Menu, and to work in full-screen mode without the menus showing. Hot keys are displayed on the Demo 3D Viewer menus in a recessed box to the right of each menu item that has a hot key.

Each hot key is represented by a single letter, number, a letter and number combination, or a control character. Typing the letter, number, specified key (such as the HOME key or the F1 key), or control sequence (e.g., the Ctrl key and the number 1, indicated as ^1) invokes the command the same way as would clicking on the menu button. The command takes effect when the key is pressed, and does not require the return or enter key to be pressed. All two-stroke hot keys are typed using the control or alternate key simultaneously with another key. The Ctrl key is shown in the program and in the documentation using the caret sign (^), and the alternate key is designated by Alt.

The hot keys are grouped and listed in approximately menu order. The functions associated with each hot key are discussed in the sections regarding the related program widget.
### Vue and Vlist Files

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read a vue file</td>
<td>Ctrl + a</td>
</tr>
<tr>
<td>Save vue file as</td>
<td>Ctrl + w</td>
</tr>
<tr>
<td>Step backward one frame in a vlist</td>
<td>Ctrl + Left Arrow</td>
</tr>
<tr>
<td>Step forward one frame in a vlist</td>
<td>Ctrl + Right Arrow</td>
</tr>
<tr>
<td>Capture a frame for a vulist (.vulist) file</td>
<td>Ctrl + r</td>
</tr>
</tbody>
</table>

### Zoom/Pan (Look Point)

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Ctrl + Shift + 1</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Ctrl + Shift + 0</td>
</tr>
<tr>
<td>Zoom in/out</td>
<td>Ctrl + Shift + Alt</td>
</tr>
<tr>
<td>Pan</td>
<td>Ctrl + Shift + X</td>
</tr>
<tr>
<td>Center view on the 3D cursor</td>
<td>Alt + K</td>
</tr>
<tr>
<td>Turn on the centering tool</td>
<td>Ctrl + x</td>
</tr>
</tbody>
</table>

### 3D Cursor

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle 3D Cursor on/off</td>
<td>Ctrl + K</td>
</tr>
<tr>
<td>Toggle 3D Cursor snapping mode on/off</td>
<td>Ctrl + Y</td>
</tr>
<tr>
<td>Move 3D Cursor to last picked point</td>
<td>J</td>
</tr>
<tr>
<td>Center view on the 3D Cursor</td>
<td>Alt + K</td>
</tr>
<tr>
<td>Add data point at 3D Cursor for active</td>
<td>Ctrl + F</td>
</tr>
<tr>
<td>edit data file</td>
<td></td>
</tr>
<tr>
<td>Move the selected data points to 3D Cursor</td>
<td>Ctrl + M</td>
</tr>
</tbody>
</table>

### Other Viewing Parameters

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flatten the Z exaggeration</td>
<td>D</td>
</tr>
<tr>
<td>Stretch the Z exaggeration</td>
<td>S</td>
</tr>
<tr>
<td>Reset Z-exaggeration and viewing parameters</td>
<td>Ctrl + H</td>
</tr>
<tr>
<td>Lock space extent and Z-exaggeration</td>
<td>Ctrl + I</td>
</tr>
<tr>
<td>Decrease azimuth of viewing angle</td>
<td>Ctrl + ←</td>
</tr>
<tr>
<td>Increase azimuth of viewing angle</td>
<td>Ctrl + →</td>
</tr>
<tr>
<td>Decrease inclination of viewing angle</td>
<td>Ctrl + ↑</td>
</tr>
<tr>
<td>Increase inclination of viewing angle</td>
<td>Ctrl + ↓</td>
</tr>
<tr>
<td>Reset slicing for selected model</td>
<td>Ctrl + End</td>
</tr>
<tr>
<td>Toggle chair mode for selected model</td>
<td>Ctrl + Ins</td>
</tr>
<tr>
<td>Toggle chair freeze mode for selected model</td>
<td>Ctrl /</td>
</tr>
<tr>
<td>Cycle back to previous dropped image for</td>
<td>Ctrl + Alt + L</td>
</tr>
<tr>
<td>selected model</td>
<td></td>
</tr>
<tr>
<td>Cycle forward to next dropped image for</td>
<td>Ctrl + Alt + R</td>
</tr>
<tr>
<td>selected model</td>
<td></td>
</tr>
</tbody>
</table>

### Data Editing

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new scattered, property, or path</td>
<td>Ctrl + N</td>
</tr>
<tr>
<td>data file</td>
<td></td>
</tr>
<tr>
<td>Add data point at 3D Cursor for active</td>
<td>Ctrl + F</td>
</tr>
<tr>
<td>edit data file</td>
<td>Ctrl + f</td>
</tr>
<tr>
<td>Delete the selected data points</td>
<td>Ctrl + D</td>
</tr>
<tr>
<td>Move the selected data points to 3D Cursor</td>
<td>Ctrl + M</td>
</tr>
</tbody>
</table>

† 3D model window must have focus for these hot keys to work
‡ On systems with a two-button mouse, the vue file parameter, twobuttonmode, can be set to assign this capability to the combination of the left and right mouse buttons together.
Display

Load a scattered, property, or path data file

Load a grid or model

Toggle axes on/off

Toggle color legend on/off

Popup the Lighting dialog

Popup the Space Manager dialog

Create a new 3D Viewer model window

<table>
<thead>
<tr>
<th></th>
<th>Alt + b</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt + b</td>
<td></td>
</tr>
<tr>
<td>Ctrl + b</td>
<td></td>
</tr>
<tr>
<td>Ctrl + a</td>
<td></td>
</tr>
<tr>
<td>Ctrl + c</td>
<td></td>
</tr>
<tr>
<td>Ctrl + l</td>
<td></td>
</tr>
<tr>
<td>Ctrl + s</td>
<td></td>
</tr>
<tr>
<td>Ctrl + v</td>
<td></td>
</tr>
</tbody>
</table>

Miscellaneous

Exit the Viewer

Exit the Viewer

Cycle from hand (manipulate) pointer mode to arrow (select)

Toggle frame rendering time box

<table>
<thead>
<tr>
<th>Esc</th>
<th>Escape</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Q</td>
<td>Ctrl + q</td>
</tr>
<tr>
<td>Tab</td>
<td>Tab</td>
</tr>
<tr>
<td>Alt + t</td>
<td>Alt + t</td>
</tr>
</tbody>
</table>

Left Mouse Button

In any mode:
- All interface selections/manipulations
- Move 3D Cursor location along 3D Cursor axes
- Slice along axes, when function enabled (on the Slice tab)
- Move magnifying glass, when function enabled (on left-hand icon column in the Model window)

In Hand mode:
- Rotate with all data displayed, unless “Mouse Drag Time Limit” is exceeded (set on the Preferences menu)
- With Shift key, rotate with all data displayed regardless of the Mouse Drag Time Limit set
- With Ctrl key, rotate with only axes and outlines displayed (on the Slice tab)

In Pointer mode:
- Select data point

Middle Mouse Button

In any mode:
- Zoom in/out in the magnifying glass, when function enabled (on left-hand icon column in the Model window)

In Hand mode:
- Zoom in/out with all data displayed, unless “Mouse Drag Time Limit” is exceeded (set on the Preferences menu)
- With Shift key, zoom in/out with all data displayed regardless of the Mouse Drag Time Limit set
- With Ctrl key, zoom in/out with only axes and outlines displayed

Right Mouse Button

In any mode:
- Close magnifying glass, when function enabled (on left-hand icon column in the Model window)

In Hand mode:
- Pan with all data displayed, unless “Mouse Drag Time Limit” is exceeded (set on the Preferences menu)
- With Shift key, pan with all data displayed regardless of the Mouse Drag Time Limit set
- With Ctrl key, pan with only axes and outlines displayed

In Pointer mode:
- In the Model window, with the pointer over a displayed file, clicking the right mouse button, displays an option menu where you can:
  - Select displayed file in the File Selection window
  - Set visibilities
  - Select data points
  - Move/delete point(s)
Appendix C: Demo 3D Viewer Glossary

This glossary covers terms referred to in The Demo 3D Viewer document.

ASCII File

An ASCII file is stored using a standard internal computer coding system which is readily displayed as characters on a terminal or sent to a printer on the computer system. ASCII files can be called plain text files.

Binary File

Binary Files are stored in an internal coding system, which uses much less space than ASCII files, and can be read or written more quickly. Faces files, 2D grids, and 3D grids are all written in binary, for example.

Clipped Data

Clipped data includes any scattered data points or 2D slice grid nodes that are specified in the grid calculation, but are not actually used for calculating the grid because they are “clipped” by one or more of the gridding parameters. Clipping can be due to the X, Y, Z, or P grid-ranges, the top or bottom 2D structure grids, the polygon file, transformation during conformal gridding, or any null or invalid values in the data set or 2D slice grid. These data are not generally displayed in the Demo 3D Viewer; however, they can be, if desired.

Color Key

The Color Key is the legend box displayed in the Demo 3D Viewer. It contains information regarding the current display, such as the isosurface intervals and their respective colors (known as the Color Table), the orientation of the axes, the Z-exaggeration, viewing angles, and the location of the X, Y, and Z slices.

Color Table

The Color Table is used to refer to the series of colors that distinguish the different isovalue shells, zones, or Z-levels.
Control Information

Control Information is any type of data that can be used to modify an output 3D property model or its associated input scattered data file. The data may, for example, come from additional boreholes for a seismic data set, previous or new studies, or additional geologic or atmospheric information. The additional data can be used to edit the scattered data file in the Demo 3D Viewer. This new edited information can then be used for recalculation of the 3D grid model. (Additional editing capabilities are available in EarthVision.)

Faces

A Faces File is the graphic file calculated from a 2D or 3D grid model, showing a single surface in space or modeled property values at user-specified isovalue intervals. The faces file is input to the Demo 3D Viewer for manipulation (e.g., slicing into the model and removing isovalue shells) and rotation. Refer to Chapter 2: 3D Viewer File Types.

Facets

Facets are the polygons that create the displayed isovalue surfaces within a faces file.

Hot Keys

Hot Keys perform certain display functions immediately upon being typed. They eliminate the need to use the mouse for selecting menu items.

Isovalue

Isovalue is defined as having the same numerical value. For example, an isovalue line is made up of points that all have the same numerical value assigned to them.

Isovalue Interval

The Isovalue Interval is the difference in P-value units between one isovalue shell and the next higher or lower shell. The interval is chosen by the user and may or may not be uniform within the 3D model. Isosurface Interval is used synonymously with Isovalue Interval.

Isovalue Level

The Isovalue Level defines the P-value of the isovalue shell (see below). The isovalue level may be defined explicitly by the user or determined by a user-specified isovalue interval.
Isovalue Shell

An Isovalue Shell is a surface boundary joining points within a 3D grid that have the same value of P. It is the three-dimensional equivalent to a contour line. Synonyms are Isovalue Surface, Isovalue Layers, and Isosurface.

Isosurface (See Isovalue Shell)
Isosurface Interval (See Isovalue Interval)
Isosurface (Isovalue Level)

P

“P” is the variable name used to stand for the property being modeled in a 3D grid. Associated with each P is an X,Y,Z location. Every scattered data file used for gridding 3D models must contain an X, Y, Z, and P field, although the names may vary.

P-value

P-value is the value of the property at a particular X,Y,Z location. P-values are the input used for gridding and also represent the grid node value.

Property Model (See 3D Grid Model)
Shell (See Isovalue Shell)
Slice

A Slice refers to a method of manipulating the display of a 3D model.

Slice (verb): To take a “slice” in the Demo 3D Viewer means to remove a portion (or volume) of the model that is often one grid cell in thickness in one direction (say the Y direction) and the full range of the model in the other two directions of the axes (the X and Z directions; this would be a “Y-slice”). A new Y-plane, which was previously interior to the model, is now an exterior face in the display. The illustration below shows a Y-slice.
Scattered Data File

A Scattered Data File contains, at a minimum, X, Y, and Z information. It can also include multiple P-fields and special fields such as a line identifier, line color, dip, dip azimuth, feature number, time, or symbols fields. The special field names are described in Chapter 2: 3D Viewer File Types. Scattered data files can be displayed in the Demo 3D Viewer without any kind of processing.

Vue Files

Vue Files are ASCII files that contain Demo 3D Viewer specifications for the proper display of faces files, ASCII scattered data files, or 2D or 3D grid files. Vue files with names ending in .vue control the display of faces files, and those ending in .dvue control the display of ASCII scattered data files.

X-column

An X-column is a plane of grid nodes perpendicular to the X-axis. In other words, every grid node within that plane has the same X-value, but different Y and Z values. Every X slice is along an X-column.

Y-row

A Y-row is a plane of grid nodes perpendicular to the Y-axis. In other words, every grid node within that plane has the same Y-value, but different X and Z values. Every Y slice is along a Y-row.

Z-level

A Z-level is a plane of grid nodes perpendicular to the Z-axis. In other words, every grid node within that plane has the same Z-value, but different X and Y values. Every Z slice is along a Z-level.
# Index

*Please note:* entries called out in **bold** type reference color images in the Demo 3D Viewer document.

## Symbols
- .bmp .................................................. 34
- .jpeg .................................................. 34
- .rgb .................................................. 34
- .tif .................................................. 34
- /* In the Viewer ...................................... 70

## Numerics
- 2D Vector .............................................. 57
- 3D Cursor ............................................... 46
- Area Calculation Using ............................... 51, 53
- Green ................................................... 52
- Hot Key .................................................. 50
- Icon Button ............................................. 50
- Marks ..................................................... 52
- Measure Using ........................................... 51, 53
- Planes ................................................... 52
- Red ....................................................... 52
- Save Locations ......................................... 52
- Snapping ............................................... 54
- Yellow ................................................... 52
- 3D Data Files ............................................ 8
  - See also Scattered Data Files
- 3D Property Model ....................................... 8, 32
  - See also 3D Grid Files
- 3D Viewer ................................................ 8, 115
  - Entering ............................................... 31
  - Hot Keys .............................................. 112
  - Initial Screen Display ................................. 31
  - Running ............................................... 31

## A
- Add Data Point .......................................... 99
- Field to File ............................................ 106
- Line after Selected Line ................................ 105
- Ambience .................................................. 39
- Analysis Menu ............................................ 47
- Animation
  - Slice ................................................... 73
- Annotation Files
  - **Surface Annotation** ................................. 17
  - Area Calculation Using 3D Cursor ................... 51, 53
  - Arrow Pointer ......................................... 55, 56
  - ASCII File Definition ................................ 115
  - Axes .................................................... 42, 54
    - Display ............................................... 46
    - Label ................................................ 46
    - Tick Marks ......................................... 46
  - Axes Labels ............................................. 42
  - Axes Orientation Diagram ............................. 32, 115
  - Axis Orientation ....................................... 47
- Azimuth
  - Reset ................................................... 61
  - Thumbwheel .......................................... 61

## B
- Background Color ....................................... 46, 60
- **Bold** Screen Annotation ............................. 69
- Boundary Slicing ......................................... 69
- Bullseye. See Centering Tool
<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tick Marks</td>
<td>46</td>
</tr>
<tr>
<td>Transparency</td>
<td>83</td>
</tr>
<tr>
<td>Tube Display</td>
<td>87</td>
</tr>
<tr>
<td>Tubes</td>
<td>9, 17</td>
</tr>
<tr>
<td>U</td>
<td>V</td>
</tr>
<tr>
<td>Underline</td>
<td>Value Box</td>
</tr>
<tr>
<td>Screen Annotation</td>
<td>Vertical Exaggeration</td>
</tr>
<tr>
<td>Undo</td>
<td>View Angle</td>
</tr>
<tr>
<td>View Menu</td>
<td>Viewer</td>
</tr>
<tr>
<td>File Selection Pane</td>
<td>Panel Window</td>
</tr>
<tr>
<td>Screen Annotation</td>
<td>Visible Tab</td>
</tr>
<tr>
<td>Vue Files</td>
<td>.vue</td>
</tr>
<tr>
<td>W</td>
<td>X</td>
</tr>
<tr>
<td>Well Data-Type Files</td>
<td>X, Y, and Z Slicing</td>
</tr>
<tr>
<td>In the 3D Viewer</td>
<td>X/Y Map View</td>
</tr>
<tr>
<td>Window Geometry</td>
<td>X/Y Plan View</td>
</tr>
<tr>
<td>Window Menu</td>
<td>X/Z Plan View</td>
</tr>
<tr>
<td>Window Tab</td>
<td>Y</td>
</tr>
<tr>
<td>in Preferences Window</td>
<td>Y/Z Plan View</td>
</tr>
<tr>
<td>Wire Frame</td>
<td>Z</td>
</tr>
<tr>
<td>X</td>
<td>Z Contouring</td>
</tr>
<tr>
<td>X/Y Map View</td>
<td>Z Exaggeration</td>
</tr>
<tr>
<td>X/Y Plan View</td>
<td>Lock</td>
</tr>
<tr>
<td>X/Z Plan View</td>
<td>Reset</td>
</tr>
<tr>
<td>Zone Menu</td>
<td>Chair Mode</td>
</tr>
<tr>
<td>Zones</td>
<td>Chair Mode</td>
</tr>
<tr>
<td>.vue</td>
<td>Zone Display</td>
</tr>
<tr>
<td>.vue</td>
<td>Zoom</td>
</tr>
<tr>
<td>.vue</td>
<td>Reset</td>
</tr>
</tbody>
</table>